This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] VF as default interface on dom0

Hi Simon,

Thanks for the reply and reproducing the problem.

I didn't tried with pv_ops kernel yet.

I guess the issue is not with the driver.  As I understand, the behavior is  because of the L2 filtering done by 82576 NIC.

The NIC filters frames based on MAC address that are assigned to VFs. In my experiment, the arp reply that reaches the NIC, has mac address of interface on VM(domU). NIC's filtering based on VF MAC address fail. So, packet is not queued to VF interface.  On dom0 a bridge is created, with VF and domUs virtual interfaces (no PF).
If we group PF interface also into this bridge, because of bridge learning functionality, the packet get routed to the virtual interface and finally to VM.

I am not 100% sure about above understanding of mine. Please, me know if you think i am wrong.


On Mon, Nov 9, 2009 at 4:41 PM, Simon Horman <horms@xxxxxxxxxxxx> wrote:
On Sun, Nov 08, 2009 at 09:09:43AM +1100, Simon Horman wrote:
> On Fri, Nov 06, 2009 at 06:35:40AM +0530, Satish Chowdhury wrote:
> > Hi,
> >
> > I am trying to make the VF interface of Intel 82576 dual port card, as
> > default outgoing interface on dom0. Data traffic from VMs (HVM) should go
> > through VF interface on dom0.
> [snip]
> > Ping from domU-1 to VF and PF ip address works.
> > Ping between domU-1 and domU-2 works.
> > But, ping from domU to another machine on same network on switch doesn't
> > work.
> >
> > The arp broadcast request goes out through VF interface. But the arp reply
> > doesn't reach VF interface, they get routed to PF interface. Why is it so?
> >
> > PF interface(eth1) is not part of the eth3 bridge. If I add eth1 to
> > eth3-bridge, then ping from VMs to other machines on switch works.
> >
> >
> > Is there something I am missing? How to make above experiment to work?
> Hi Staish,
> I suspect that there is some kind of driver issue. Unfortunately
> the building that the dc7800 that I use is undergoing power-maintenance
> (= power-outage) today, so I can't investigate right now.

The machine came back up and I seem to be able to reproduce the problem.
Unfortunately I still don't have any firm ideas on how to fix it.

Have you tried the same thing with the pv_ops kernel, which is
based on a new kernel rather than 2.6.18, which is quite ancient.
I'm curious to know if the problem exists when using possibly more up
to date drivers.

Xen-devel mailing list