This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-users] GPLPV drivers update

To: "'James Harper'" <james.harper@xxxxxxxxxxxxxxxx>, <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-users] GPLPV drivers update
From: "Robbie Garrett" <rgarrett@xxxxxxxxxxxxxx>
Date: Tue, 25 Aug 2009 14:29:44 -0400
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Delivery-date: Tue, 25 Aug 2009 11:30:33 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <AEC6C66638C05B468B556EA548C1A77D0177CDDE@trantor>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <AEC6C66638C05B468B556EA548C1A77D0177CDDE@trantor>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcolLPmqGxJzVidST8mIfKrxx23DQAAhNrJQ
Using the newest drivers, the installer fails with 'the installer ended

-----Original Message-----
From: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
[mailto:xen-users-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of James Harper
Sent: Monday, August 24, 2009 10:37 PM
To: xen-users@xxxxxxxxxxxxxxxxxxx
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] GPLPV drivers update

I have just uploaded a new testing version of GPL PV drivers for
Windows. Have a look for at
http://www.meadowcourt.org/downloads (the -dontuse bit is to scare
people away who haven't read this email :)

As usual, please test thoroughly on a test DomU and make sure you have a
backup before installing on a non-test system. In particular, I'm only
testing with Xen 3.4.1 these days so anything older isn't tested
although it should work.

There was a problem with the signing of the drivers that would prevent
them working properly under Vista/2008 x64 even with testsigning
enabled. This should resolve that.

The installation procedure for Vista/2008 x64 is as follows:
. Run 'bcdedit /set testsigning on'
. Reboot
. Install the drivers. Accept any warnings and tick 'always trust...'
when prompted.
. Make sure you now have PV network and SCSI adapters present
. Reboot

If something doesn't work, you should be able to boot to safe mode
unless you forgot to run 'bcdedit /set testsigning on' in which case you
will probably have an unbootable system... for some reason the vista F8
boot menu doesn't allow you to turn on testsigning and safe mode at the
same time. Ideally the installer would be able to detect that we are
using a test certificate and instruct you to turn on testsigning first
but I don't yet know how to do that. I'll see if I can at least put in a
loud warning at installation time...


Xen-users mailing list

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>