This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Vt-d not working with 3.4.1

To: enming.teo@xxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] Vt-d not working with 3.4.1
From: "Mr. Teo En Ming (Zhang Enming)" <enming.teo@xxxxxxxxxxxxxxx>
Date: Fri, 21 Aug 2009 01:00:41 +0800
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, weidong.han@xxxxxxxxx, mad@xxxxxx, "'Bonenkamp, Ralf'" <ralf.bonenkamp@xxxxxxxx>
Delivery-date: Thu, 20 Aug 2009 10:01:16 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4A8D7C9E.30503@xxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <833F02C491734E2BAA6CB4265638A47A@ASOITIS16> <4A8D7C9E.30503@xxxxxxxxxxxxxxx>
Reply-to: enming.teo@xxxxxxxxxxxxxxx
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20090814 Fedora/3.0-2.6.b3.fc11 Thunderbird/3.0b3

I saw this posting by Boris.


Perhaps the Xen dom 0 pvops kernel I am using is too new (2.6.30-rc3), and the NVIDIA driver I am using does not support it.


Mr. Teo En Ming (Zhang Enming) Dip(Mechatronics Engineering) 
BEng(Hons)(Mechanical Engineering)
Technical Support Engineer
Information Technology Department
Asiasoft Online Pte Ltd
Tampines Central 1 #04-01 Tampines Plaza
Singapore 529541
Republic of Singapore
Mobile: +65-9648-9798
MSN: teoenming@xxxxxxxxxxx
Alma Maters: Singapore Polytechnic, National University of Singapore

On 08/21/2009 12:41 AM, Mr. Teo En Ming (Zhang Enming) wrote:
Dear All,

I followed the XEN - NVIDIA - STEP BY STEP instructions at nV news forums but I still couldn't get X to work under Xen pv-ops domain 0 kernel. It still shows me a freezed blank screen. I couldn't switch to any tty (1 to 7 inclusive).

Here are the scenarios I have tried:

1)     IGNORE_XEN_PRESENCE=y ./NVIDIA-Linux-x86_64-185.18.31-pkg2.run

2) IGNORE_XEN_PRESENCE=y CC="gcc -DNV_VMAP_4_PRESENT -DNV_SIGNAL_STRUCT_RLIM" ./NVIDIA-Linux-x86_64-185.18.31-pkg2.run


./NVIDIA-Linux-x86_64-185.18.31-pkg2.run --extract-only

cd usr/src/nv

IGNORE_XEN_PRESENCE=y CC="gcc -DNV_VMAP_4_PRESENT -DNV_SIGNAL_STRUCT_RLIM" make SYSSRC=/usr/src/kernels/2.6.30-rc3-enming.teo-tip module

cp nvidia.ko /lib/modules/2.6.30-rc3-enming.teo-tip/kernel/drivers/video

cd /lib/modules/2.6.30-rc3-enming.teo-tip/kernel/drivers/video

depmod -a

rmmod nvidia

lsmod | grep nvidia

modprobe nvidia

lsmod | grep nvidia

None of the above three scenarios I have attempted worked for me.

When I tried to load the newly compiled nvidia driver (against the Xen Domain 0 paravirt operations kernel), it gives me the following message:

NVRM: loading NVIDIA UNIX x86_64 Kernel Module 185.18.31 Tue Jul 28 17:52:27 PDT 2009

NVRM: PAT configuration unsupported, falling back to MTRRs.

Any more ideas?

My home PC configuration:

Intel Pentium processor E6300 LGA775
Intel Desktop Board DQ45CB
BIOS Version 0093
8 GB DDR2-800
NVIDIA Geforce 8400 GS 512 MB DDR2 PCI Express x16

Fedora 11 64-bit Host operating system
Xen hypervisor 3.4.1
Jeremy Fitzhardinge's pv-ops dom 0 Xen kernel 2.6.30-rc3 and 2.6.31-rc6
Default shipping X server
mesa-lib upgraded

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>