This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Re: [pv_ops domU] - unable to handle kernel paging

To: "Christopher S. Aker" <caker@xxxxxxxxxxxx>
Subject: [Xen-devel] Re: [pv_ops domU] - unable to handle kernel paging request / refresh_cpu_vm_stats / vmstat_update
From: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Date: Tue, 18 Aug 2009 13:15:14 -0700
Cc: xen devel <xen-devel@xxxxxxxxxxxxxxxxxxx>, Keir Fraser <keir.fraser@xxxxxxxxxxxxx>
Delivery-date: Tue, 18 Aug 2009 13:15:35 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4A8AB7B8.4070905@xxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <4A89F539.2070801@xxxxxxxxxxxx> <4A8A2E74.9010202@xxxxxxxx> <4A8AB7B8.4070905@xxxxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20090814 Fedora/3.0-2.6.b3.fc11 Thunderbird/3.0b3
On 08/18/09 07:16, Christopher S. Aker wrote:
> Jeremy Fitzhardinge wrote:
>> Does this happen every time, sometimes or just once?
> Completely reproducible, however I was wrong about the Xen version -
> it is 3.2.1-rc5.  FWIW, I'm unable to reproduce this on a dev box
> running 3.4.1.

That's curious.  Keir, do you know of any bugs which could cause domU
misbehaviour like this?

> I haven't tried any other Xen versions (we have many running).
>> Is it new with
> Yes.  The last pv_ops kernel we ran was 2.6.29.

Have you tried any other distros?  I'll try to repro with a current Xen
and my Fedora system.

It would be helpful if you could try 2.6.30/.[1-4] as well to see if the
problem arises.  I'm trying a bisection myself, but it sounds like I
shouldn't be able to repo it.


Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>