This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] MMCFG Problem

To: "Kay, Allen M" <allen.m.kay@xxxxxxxxx>
Subject: [Xen-devel] MMCFG Problem
From: Simon Horman <horms@xxxxxxxxxxxx>
Date: Fri, 7 Aug 2009 16:51:13 +1000
Cc: xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Thu, 06 Aug 2009 23:51:37 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.18 (2008-05-17)
Hi Allen, Hi All,

I'm looking into SR-IOV on Xen and in particular getting
the VFs of the Intel 82756 initialised in dom0.

One problem that I am coming up against is that
the SRIOV extended PCIe capability does not show up
for the PF (physical PCI function). Actually,
the extended PCIe capability space doesn't show up
at all for any device.

This seems to be related to a failure to initialise mmconfig.

I'm running the latest xen-unstable.hg tree with
(although I have tried various other kernels too). The machine
is an HP dc7800 running in x86_64 mode. In the logs I am seeing:

ACPI: RSDP (v000 COMPAQ                                ) @ 0x00000000000e5c10
ACPI: RSDT (v001 HPQOEM SLIC-BPC 0x20090226  0x00000000) @ 0x00000000defc1e40
ACPI: FADT (v001 COMPAQ BEARLAKE 0x00000001  0x00000000) @ 0x00000000defc1ee8
ACPI: MADT (v001 COMPAQ BEARLAKE 0x00000001  0x00000000) @ 0x00000000defc1f5c
ACPI: ASF! (v032 COMPAQ BEARLAKE 0x00000001  0x00000000) @ 0x00000000defc1fe0
ACPI: MCFG (v001 COMPAQ BEARLAKE 0x00000001  0x00000000) @ 0x00000000defc2043
ACPI: TCPA (v001 COMPAQ BEARLAKE 0x00000001  0x00000000) @ 0x00000000defc207f
ACPI: SLIC (v001 HPQOEM SLIC-BPC 0x00000001  0x00000000) @ 0x00000000defc20b1
ACPI: HPET (v001 COMPAQ BEARLAKE 0x00000001  0x00000000) @ 0x00000000defc2227
(XEN) PCI: MCFG configuration 0: base f4000000 segment 0 buses 0 - 63
(XEN) PCI: MCFG area at f4000000 reserved in E820
ACPI: bus type pci registered
(XEN) mm.c:762:d0 Non-privileged (0) attempt to map I/O space 000fec00
PCI: Cannot map mmconfig aperture for segment 0
PCI: Using configuration type 1

Any pointers on what to poke would be greatly appreciated.

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>