This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] [PATCH]Fix vlapic.h type

To: Patrick Colp <Patrick.Colp@xxxxxxxxxx>
Subject: Re: [Xen-devel] [PATCH]Fix vlapic.h type
From: Tim Deegan <Tim.Deegan@xxxxxxxxxx>
Date: Wed, 8 Jul 2009 10:33:46 +0100
Cc: Wei Huang <wei.huang2@xxxxxxx>, Neil Turton <nturton@xxxxxxxxxxxxxx>, "'xen-devel@xxxxxxxxxxxxxxxxxxx'" <xen-devel@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Wed, 08 Jul 2009 02:34:09 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4A546757.5030205@xxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <4A53BC08.1040100@xxxxxxx> <4A544B76.6000304@xxxxxxxxxx> <4A5463A6.5030001@xxxxxxxxxxxxxx> <4A546757.5030205@xxxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.17 (2007-11-01)
At 10:31 +0100 on 08 Jul (1247049063), Patrick Colp wrote:
> Neil Turton wrote:
> > Patrick Colp wrote:
> >> Good catch. This line:
> >>
> >>   #define vlapic_vcpu(vpic)   (container_of((vpic), struct vcpu, \
> >>                                             arch.hvm_vcpu.vlapic))
> >>
> >> should probably also be changed to this:
> >>
> >>   #define vlapic_vcpu(vlapic)   (container_of((vlapic), struct vcpu, \
> >>                                               arch.hvm_vcpu.vlapic))
> > 
> > I'm not sure.  Do you intend to change the member name after hvm_vcpu
> > based on the macro parameter?
> No. Why would I do that?
> The issue here is that the macro parameter is referring to a vlapic and not a 
> vpic (which is something different). So for the sake of clarity, it should be 
> changed to vlapic instead of vpic.

but vlapic_vcpu(oops) would expand to  
 (container_of((oops), struct vcpu, arch.hvm_vcpu.oops)


Tim Deegan <Tim.Deegan@xxxxxxxxxx>
Principal Software Engineer, Citrix Systems (R&D) Ltd.
[Company #02300071, SL9 0DZ, UK.]

Xen-devel mailing list