This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Re: kernel BUG at arch/x86/xen/multicalls.c:204!

To: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Subject: [Xen-devel] Re: kernel BUG at arch/x86/xen/multicalls.c:204!
From: Rambaldi <rambaldi@xxxxxxxxx>
Date: Tue, 07 Jul 2009 20:24:11 +0200
Cc: Xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>, linux-kernel@xxxxxxxxxxxxxxx
Delivery-date: Tue, 07 Jul 2009 11:24:42 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <4A222E7C.3030504@xxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <4A20F23D.4080504@xxxxxxxxx> <4A21CE1C.1090204@xxxxxxxx> <4A222E7C.3030504@xxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20090628)
Rambaldi wrote:
> Jeremy Fitzhardinge wrote:
>> Rambaldi wrote:
>>> Hi,
>>> while booting the 2.6.29-gentoo-r5 kernel as xen domU guest I got the
>>> following kernel BUG.
>>> I have not tried a vanilla 2.6.29 kernel, but can if requested,
>>> .config is also available on reguest.
>> That would be useful, particularly if you enable the various debugging
>> options:
>> It's not clear to me what's failing.  Are there any messages on the Xen
>> concole (xm dmesg)?
>>    J
> Hi Jeremy,
> thanks for looking at it.
> I tried with a vanilla kernel. I added CONFIG_FRAME_POINTER. 
> CONFIG_DEBUG_KERNEL was already set.
> I got the same result as with the gentoo kernel and in both cases not a 
> single line in the xen console.
> Any other options or kernels I can try?
> tia
> R

Hi Again,

it has been a while, but I finally found the setting that caused this issue.
by removing:
        Configure Maximum number of SMP Processors and NUMA Nodes

I can boot my sytem again without the kernel BUG.

hope this helps



Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-devel] Re: kernel BUG at arch/x86/xen/multicalls.c:204!, Rambaldi <=