This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] HVM pvops failures (one more qemu-dm.strace obtained)

To: Jeremy Fitzhardinge <jeremy@xxxxxxxx>
Subject: Re: [Xen-devel] HVM pvops failures (one more qemu-dm.strace obtained)
From: Andrew Lyon <andrew.lyon@xxxxxxxxx>
Date: Wed, 18 Mar 2009 08:17:48 +0000
Cc: Ian Campbell <Ian.Campbell@xxxxxxxxxxxxx>, Boris Derzhavets <bderzhavets@xxxxxxxxx>, "xen-devel@xxxxxxxxxxxxxxxxxxx" <xen-devel@xxxxxxxxxxxxxxxxxxx>, Ian Jackson <Ian.Jackson@xxxxxxxxxxxxx>
Delivery-date: Wed, 18 Mar 2009 01:18:18 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=11vwz6A4nNrgdUiKPU/04AqFfM4zOkw3OT7xcX7AqQg=; b=dT45Kin7djQb2ZX5aGKgs1/MD609LMwhfMP5YffcGy5qVNKJpb7XZCxJGdjJ5XtVPB SQJwBnU1aZqBRsEy2ocM/WQm8utuSxJ27ncPpyfDKkbKd19t+zyvtjVhc+50zrtAKlGl GM2GLDmSZBUnvp5ne1DhJT8oHBH8p/FMLLh4I=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=XcFSdpD4+DOvB2QYrUsOAyuyOJEQD7M9zmJ08nPbqhI07hURY7PlVHfFfLASkDLmQB /m3UlpP33/eq0EWnuKAx/n0vzhzePx2E/xDOrOoRyPwYBj9HiXF/caZHP9lkYVvBI1gD PI/oTEuOvEWG2uQmRy3iFWEUTkDTgoUzBQhDM=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <49AD6BD0.8010006@xxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <49A33B62.1050303@xxxxxxxx> <80518.15147.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx> <f4527be0902250628o4c2c46b5j2db93d8665e13a77@xxxxxxxxxxxxxx> <49A5B1D2.8050003@xxxxxxxx> <18854.32386.340159.586295@xxxxxxxxxxxxxxxxxxxxxxxx> <f4527be0903030255r3f13810ex76af484c46f23b67@xxxxxxxxxxxxxx> <49AD6BD0.8010006@xxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
On Tue, Mar 3, 2009 at 5:41 PM, Jeremy Fitzhardinge <jeremy@xxxxxxxx> wrote:
> Andrew Lyon wrote:
>> On Thu, Feb 26, 2009 at 11:35 AM, Ian Jackson <Ian.Jackson@xxxxxxxxxxxxx>
>> wrote:
>>> Jeremy Fitzhardinge writes ("Re: [Xen-devel] HVM pvops failures (one more
>>> qemu-dm.strace obtained)"):
>>>> I was hoping Ian J would pop up and say "Its broken like this!  Fix it
>>>> like this!".
>>> Yes, when I have a moment I'll try it myself but I've been buried in
>>> the bowels of a nightmare USB emulation.  Soon I'll know whether the
>>> latter works and thus whether I have any time to dig into pvops.
>>> Ian.
>> Has anybody made any progress on the qemu-dm / hvm issue with pv_ops?
>> I spent most of yesterday going through the strace logs but I cannot
>> see why it fails as it does.
> Thanks for looking into this.  The crash is a SIGBUS in qemu, shortly after
> an mmap of /proc/xen/privcmd, which is a suspicious combination.  The SIGBUS
> means we managed to create a mapping where the kernel thinks there are no
> backing pages (at least in part).  It would be useful to know if any memory
> accesses to the privcmd mapping succeed, and what the offset of the failing
> one is.  (Assuming the SIGBUS is related to a privcmd mapping at all.)
> I don't think privcmd mappings can be completely broken, because the qemu
> backend for pvfb works fine, and I assume that uses that path to map the
> framebuffer...
> Also, have you tried using stub domains?  They should have no dependence on
> the dom0 kernel at all, so in theory they should work regardless.
>   J

I tried Stub domains yesterday but as soon as I "xm create" the system
locked up, I could still ping it but no response on the serial console
and ssh was responsive, very strange.. I've never seen a system ping
but have unresponsive console.

Can we try to debug the problem with hvm on pv_ops?


Xen-devel mailing list