This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Re: FC9 - xen kernel does not boot....

To: kushal waikar <kushalwaikar@xxxxxxxxxxx>
Subject: [Xen-users] Re: FC9 - xen kernel does not boot....
From: Peter Teoh <htmldeveloper@xxxxxxxxx>
Date: Sun, 15 Mar 2009 18:01:18 +0800
Cc: xen-devel@xxxxxxxxxxxxxxxxxxx, xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Sun, 15 Mar 2009 03:01:56 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:in-reply-to:references :date:message-id:subject:from:to:cc:content-type :content-transfer-encoding; bh=w8LwkYwZqw/0f7Gx3Jfx+Y/I+Hde+nhEmUjJ2ubtt3I=; b=AzmYMzAtcBZR+DO/uyHCil8sAin8Usb2VqlnLt5UFqNaueIytmg8nDmkbcX9R6nH3V E6N1eFt430zTXCD6tnlVGqSZK6k7PE4toE6legaKGB8w0y9mWQvvvVsy5y+J6Qjrmm3N ZIQ4ZQ0Nx1v/3coKgbw8Mm0MvLSkmct4+/4nE=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=bFRG7ZenihM1NKrPIdpbRRa/LuTAu5YmNyg3CUYxPMFSXImYfS0tbCA4bD0uYntGUZ 5ImoH4oGB8Jl4wpEPleUrZa5ZE6zL5e/Ss2l2eyMwiIAOtmSATuWi8MRT3MZII0lHpIm 2sZeWIaNxzjd6OBBAKNMHHxtw4X/M2zhXSLQI=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <576367.30673.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <576367.30673.qm@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
have not tried it myself, but according to "marko":


FC8 is the last version that have Dom0 support.

On Sun, Mar 15, 2009 at 3:28 PM, kushal waikar <kushalwaikar@xxxxxxxxxxx> wrote:
> Hi,
> I recently installed the "Xen 3.2"(which comes with FC9)while installing
> FC9...Previously I have installed the "Xen"(which comes with FC8)....When I
> install Xen with FC8 I get Xen boot Option but when I install it with FC9 in
> the same manner I dont get Xen boot option...I am not getting how to install
> Xen on FC9....I have heard that FC9 doesnt have Dom0 support...
> I have tried to install "Xen 3.3" from source code...i used following
> steps-->
> 1. make install-tools   ---> NO ERROR
> 2. make install-stubdom   ---> NO ERROR
> 3. make install-xen   ---> NO ERROR
> 4. make install-docs   ---> NO ERROR

Personally I have not tried FC9, but for FC10, which does not comes
with Dom0 support, I have tried compiling the source from XenSource
directly.   Compilation gone through successfully all the way ("make
world") and hypervisor booted, followed by Dom0 booting up.
Everything was ok except when it comes to mouse/keyboard input
detection it never managed to detect.   After "start udev" it again
encountered another "eth0" not detected error.   Nevertheless the
startup continued successfully to the login screen.

I camera-captured the error at the mouse detection - anyone interested
can request for it.   Never have seen any step-by-step howto on
compiling the Xensource for the FC10 environment either.

Any advice from Xen developers are welcome :-).

> But still not able to install it on FC9..
> Any kind of help will be appreciated..
> Thanks,
> Kushal waikar
> kushalwaikar@xxxxxxxxxxx


Peter Teoh

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>