This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] Xen not getting out of S3

To: Ron Reiter <ron@xxxxxxxxxxxx>, <xen-devel@xxxxxxxxxxxxxxxxxxx>
Subject: Re: [Xen-devel] Xen not getting out of S3
From: Keir Fraser <keir.fraser@xxxxxxxxxxxxx>
Date: Wed, 13 Aug 2008 07:28:53 +0100
Delivery-date: Tue, 12 Aug 2008 23:29:16 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <9392A06CB0FDC847B3A530B3DC174E7B05A8AF80@xxxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: Acj7xyZNDyjD+CdvQGWLDEoVpwNk+ABRrSpC
Thread-topic: [Xen-devel] Xen not getting out of S3
User-agent: Microsoft-Entourage/
Our suspicion is that this is due to the __initdata attribute on the variable mce_disabled in xen/arch/x86/cpu/mcheck/mce.h. If you can rebuild your hypervisor you could remove that attribute and confirm the fix. I’ll be applying it for 3.3.0 and 3.2.2 anyway.

 -- Keir

On 11/8/08 16:30, "Ron Reiter" <ron@xxxxxxxxxxxx> wrote:

After quite a lot of playing with pm-suspend quirks, I've managed to figure out that Xen does not wake up from suspend correctly on my HP Compaq 6510b.
I am running Ubuntu 8.04 with Xen-3.2.1.
I've tried suspending from console, VESA X and accelerated X (Intel Mobile GM965/GL960 Integrated).
When Xen is not running, suspending from X works correctly (There are a few issues such as that the backlight does not turn on when using VESA), while from console it does not (for some strange reason).
When I restore the computer from sleep state with Xen, the fan starts working, but the computer freezes completely and no devices return from sleep (such as wifi).
I've also tried playing with Xen's acpi_sleep boot option (s3_mode, s3_bios) and no combination of the flags works.
I was able to suspend Xen once correctly with the command "pm-suspend" with no arguments, but I am not able to reproduce this.
Does anyone have any idea why this happens?
-- Ron

Xen-devel mailing list

Xen-devel mailing list
<Prev in Thread] Current Thread [Next in Thread>