This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] can't boot 32-bit SLES10 HVMs since c/s 14436wasintroduc

To: "Krysan, Susan" <KRYSANS@xxxxxxxxxx>, "Keir Fraser" <Keir.Fraser@xxxxxxxxxxxx>, <xen-devel@xxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-devel] can't boot 32-bit SLES10 HVMs since c/s 14436wasintroduced
From: "Cui, Dexuan" <dexuan.cui@xxxxxxxxx>
Date: Tue, 8 May 2007 00:30:20 +0800
Delivery-date: Mon, 07 May 2007 09:29:02 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <EF8D308BE33AF54D8934DF26520252D303504862@xxxxxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thread-topic: [Xen-devel] can't boot 32-bit SLES10 HVMs since c/s 14436wasintroduced

Sorry, I just saw the mail (in our side, the past week was a long public holiday).


It seems the issue hasn’t been fixed till now?  I can’t see why the lower-the-freq-of-vHPET changeset should cause the issue…


I remember booting 32bit SLES 10 SP1 RC2 HVM guest on 64bit Bensley host is ok, per some previous mail (pls see the attachment for it).

Does this mean the issue only happens to Unisys ES7000, and doesn’t happen to Bensley?


-- Dexuan


From: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx [mailto:xen-devel-bounces@xxxxxxxxxxxxxxxxxxx] On Behalf Of Krysan, Susan
Sent: 2007
52 23:43
To: Keir Fraser; xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: RE: [Xen-devel] can't boot 32-bit SLES10 HVMs since c/s 14436wasintroduced


Yes, I saved this output from the 32-bit SMP (non-PAE) HVM when I ran with changeset 14756:


<0>Kernel panic ? not syncing: Fatal exception in interrupt

Badness in smp_call_function at arch/i386/kernel/smp.c:595

[<c010dc2a>] smp_call_function+0x56/0x104

[<c011a7cf>] printk+0x14/0x18

[<c010dceb>] smp_send_stop+0x13/0x1c

[<c0119ed8>] panic+0x4c/0xe4

[<c010421a>] die+0x1dd/0x1e7

[<c0104836>] do_invalid_op+0x0/0x9d

[<c01048c7>] do_invalid_op+0x91/0x9d

[<f886173d>] ide_timer_expiry+0x90/0x257 [ide_core]

[<c02001e4>] vt_console_print+0x0/0x212

[<c0119fde>] __call_console_drivers+0x34/0x40

[<c011a263>] release_console_sem+0x15a/0x194

[<c011a797>] vprintk+0x23f/0x263

[<f8861351>] ide_intr+0x17f/0x18a [ide_core]

[<c0135a92>] handle_IRQ_event+0x23/0x4c

[<f8867694>] ide_dma_intr+0x0/0x8f [ide_core]

[<c0103a2f>] error_code+0x4f/0x60

[<f8867694>] ide_dma_intr+0x0/0x8f [ide_core]

[<f886007b>] ide_uevent+0xab/0xfe [ide_core]

[<f886173d>] ide_timer_expiry+0x90/0x257 [ide_core]

[<c012007b>] do_sysctl+0x1b1/0x21f

[<c0121f90>] run_timer_softirq+0x128/0x18c

[<f88616ad>] ide_timer_expiry+0x0/0x257 [ide_core]

[<c011e544>] __do_softirq+0x58/0xc2

[<c011e5dc>] do_softirq+0x2e/0x32

[<c0104cb7>] do_IRQ+0x4b/0x53

[<c010387a>] common_interrupt+0x1a/0x20

[<c0141fe7>] __handle_mm_fault+0x3f8/0x7e8

[<c028524e>] do_page_fault+0x16e/0x525

[<c02850e0>] do_page_fault+0x0/0x525

[<c0103a2f>] error_code+0x4f/0x60



Sue Krysan

Linux Systems Group

Unisys Corporation


From: Keir Fraser [mailto:Keir.Fraser@xxxxxxxxxxxx]
Sent: Tuesday, May 01, 2007 4:59 PM
To: Krysan, Susan; xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] can't boot 32-bit SLES10 HVMs since c/s 14436 wasintroduced


On 1/5/07 18:49, "Krysan, Susan" <KRYSANS@xxxxxxxxxx> wrote:

I cannot boot 32-bit SLES10 HVMs, SMP nor PAE, on x86_64 SLES10 xen on Unisys ES7000/one with Intel processors.  I initially tried with HVM memory sizes of 2gb and 16gb, but when I give the HVMs only 512mb, they still do not boot.  I have run both with the ES7000 configured as 8x 32gb and 16x 64gb.  The HVMs either hang in the graphical blue SUSE Linux screen or get this kernel panic: Badness in smp_call_function at arch/i386/kernel/smp.c:595.    

At Keir’s suggestion, I used a binary search method to narrow down changesets, and after building and testing multiple changesets I was able to determine

When you get the ‘Badness in smp_call_function’ message, do you also get a backtrace and/or stack dump?

 -- Keir

Attachment: RE Xen-devel can't boot 32-bit SLES10 HVMs using c s 14875 onx86_64Xen.msg
Description: RE Xen-devel can't boot 32-bit SLES10 HVMs using c s 14875 onx86_64Xen.msg

Xen-devel mailing list