This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] nvidiafb in domU causes cpu to lockup

To: "Mark Hurenkamp" <mark.hurenkamp@xxxxxxxxx>, <xen-devel@xxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-devel] nvidiafb in domU causes cpu to lockup
From: "Ian Pratt" <Ian.Pratt@xxxxxxxxxxxx>
Date: Thu, 3 May 2007 23:54:54 +0100
Delivery-date: Thu, 03 May 2007 15:54:02 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <37473.>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AceN0s0lcVBGiyG2ThehJyjWKwfYmQAAyWUQ
Thread-topic: [Xen-devel] nvidiafb in domU causes cpu to lockup
> I've been playing with X in domU again, got succesfull once, but find
> it hard to reproduce because nvidiafb keeps locking up.
> My setup is a Centos5 system, using 2 nvidia cards, and 2 usb cards.
> I assign the PCI Graphics card and one usb card to DomU using pciback,
> which seems to work great.
> The problem occurs when I want to modprobe nvidiafb in DomU, almost
> the time it locks up, thus I am unable to use it as a display device
> for X.
> I tried with and without X running in dom0 (using nv driver in dom0 by
> the
> way)

Does the nvidiafb driver work reliably in dom0? Even if you build xen
with debug=y ?

> I also tried to start X in domU with nv driver, but that gives a
> different
> error:
>     Fatal server error:
>     xf86MapVidMem: Could not mmap framebuffer (0x000a0000,0x20000)
> address)

This may help with the above issue:


Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>