This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] nvidiafb in domU causes cpu to lockup

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] nvidiafb in domU causes cpu to lockup
From: "Mark Hurenkamp" <mark.hurenkamp@xxxxxxxxx>
Date: Fri, 4 May 2007 00:30:55 +0200 (CEST)
Delivery-date: Thu, 03 May 2007 15:28:56 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
Importance: Normal
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: SquirrelMail/1.4.3a

I've been playing with X in domU again, got succesfull once, but find
it hard to reproduce because nvidiafb keeps locking up.
My setup is a Centos5 system, using 2 nvidia cards, and 2 usb cards.
I assign the PCI Graphics card and one usb card to DomU using pciback,
which seems to work great.
The problem occurs when I want to modprobe nvidiafb in DomU, almost all
the time it locks up, thus I am unable to use it as a display device
for X.
I tried with and without X running in dom0 (using nv driver in dom0 by the

I also tried to start X in domU with nv driver, but that gives a different
    Fatal server error:
    xf86MapVidMem: Could not mmap framebuffer (0x000a0000,0x20000) (Bad


PCI: Enabling device 0000:00:00.0 (0000 -> 0002)
nvidiafb: Device ID: 10de0322
nvidiafb: CRTC0 analog found
nvidiafb: CRTC1 analog not found
nvidiafb: CRTC 0 appears to have a CRT attached
nvidiafb: Using CRT on CRTC 0
nvidiafb: unable to setup MTRR
Console: switching to colour frame buffer device 80x30
nvidiafb: PCI nVidia NV32 framebuffer (2MB @ 0xD0000000)
BUG: soft lockup detected on CPU#1!
 [<c043ea67>] softlockup_tick+0x98/0xa6
 [<c0408b7d>] timer_interrupt+0x504/0x557
 [<c043ec9b>] handle_IRQ_event+0x27/0x51
 [<c043ed58>] __do_IRQ+0x93/0xe8
 [<c040672b>] do_IRQ+0x93/0xae
 [<c053a045>] evtchn_do_upcall+0x64/0x9b
 [<c0404ec5>] hypervisor_callback+0x3d/0x48
 [<d123f8f1>] NVDmaWait+0xab/0x14b [nvidiafb]
 [<d123fb64>] nvidiafb_imageblit+0x1d3/0x35f [nvidiafb]
 [<c04efe8f>] bit_putcs+0x40f/0x45a
 [<c04ead3d>] fbcon_clear_margins+0x3a/0x3d
 [<d123aab1>] nvidia_write_clut+0x4b/0x59 [nvidiafb]
 [<c04eb2e3>] fbcon_putcs+0x1d7/0x222
 [<c04efa80>] bit_putcs+0x0/0x45a
 [<c0522b9f>] do_update_region+0xcb/0x101
 [<c0524ad6>] redraw_screen+0x147/0x182
 [<c04ecb82>] fbcon_blank+0x12f/0x15c
 [<c0524bd1>] do_unblank_screen+0xc0/0xfe
 [<c051ed26>] vt_ioctl+0x470/0x143e
 [<c051e8b6>] vt_ioctl+0x0/0x143e
 [<c051b774>] tty_ioctl+0xb0e/0xb95
 [<c04b0091>] avc_has_perm+0x3a/0x44
 [<c04b0689>] inode_has_perm+0x54/0x5c
 [<c05f63b8>] do_page_fault+0x6e8/0xbeb
 [<c05f6431>] do_page_fault+0x761/0xbeb
 [<c04b0710>] file_has_perm+0x7f/0x88
 [<c0471a27>] do_ioctl+0x47/0x5d
 [<c0471c87>] vfs_ioctl+0x24a/0x25c
 [<c0471ce1>] sys_ioctl+0x48/0x5f
 [<c0404cff>] syscall_call+0x7/0xb

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>