This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] X in dom1 with second graphics card?

To: xen-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-devel] X in dom1 with second graphics card?
From: Julian Davison <julian@xxxxxxxxxxxxxxxxxxx>
Date: Thu, 28 Sep 2006 08:20:54 +1200
Delivery-date: Thu, 28 Sep 2006 01:35:31 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <451A992C.4000108@xxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <451A992C.4000108@xxxxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Windows/20060909)
Mark Hurenkamp wrote:

It's been a while since I tried, so I decided to upgrade my system
again to the latest Xen (3.0.2), and see how far I can get with a X
session on a dom1, using a second graphics, usb and audio card.

X is fun :)

After reading about Bernhard Kuhns configuration I got optimistic
about getting this configuration running.
(see http://wiki.xensource.com/xenwiki/CoolConfigurations )

However, I don't seem to be able to get passed the console tty
issue, which X somehow still seems to be needing:

   Fatal server error:
   xf86OpenConsole: Cannot open /dev/tty0

I tried creating the device with mknod, but although it now exists,
X is still not able to open it. (tried a cat /dev/tty0, didn't work either,
so I guess the device really doesn't exist in Xen dom1 ).

Bernhard seems to have managed to get it to work somehow...
Anyone know how?

I gave up trying to sort this particular problem
out. I was using Debian Sarge for Dom0 and DomU and
found various suggestions (with google) of things to
try, most of which didn't apply to the version of X
in Sarge. Upgrading through to a more recent xorg
either from unstable, or using backports.org led to
much happier experiences.

With xorg and the command:
    X -novtswitch -sharevts vt1
I then ran into more standard problems with the X display
driver talking to the graphics card.

Full details on what we were looking for are in my
previous posts here, under "X11 on domU", but, briefly,
we want multi-head/seat on a single box using the
on-board AGP and additional PCI graphics cards, using
USB for input devices (sound not required). We're
actually after 3 domU's each with their own X and no
console on the dom0.
Using the pciback driver it was fairly straightforward
to present domU with graphics and USB, though Xen needed
a little tweak to make the VGA memory range available
to the driver (I had help with this, so I only partially
follow it :)

Ultimately I had two problems getting it to work,
one was the i810 driver accessing memory, which stopped
X working in domU at all, the other was the second card
I had installed turned out to cause display corruption
when in X (but had no visible effect on the console).
The final problem is one of time, which is why I can't
actually say I've done it, as yet :)

X11 in domU, yes, but not two at once.

Julian Davison, ICT Technician
Christchurch Boys' High School

Xen-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>