This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


RE: [Xen-devel] Xenoprof: getting Oprofile out of timer mode?

To: "Ray Bryant" <raybry@xxxxxxxxxxxxxxxxx>, <xen-devel@xxxxxxxxxxxxxxxxxxx>
Subject: RE: [Xen-devel] Xenoprof: getting Oprofile out of timer mode?
From: "Santos, Jose Renato G" <joserenato.santos@xxxxxx>
Date: Sat, 20 May 2006 23:53:01 -0700
Cc: Gitika Aggarwal <gitika@xxxxxxxxx>, Andrei Lifchits <alifchit@xxxxxxxxx>
Delivery-date: Sat, 20 May 2006 23:53:30 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <200605191704.04181.raybry@xxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcZ7kDW0vd/vPD/CRi+ZwNOhkkb45wBEMM/Q
Thread-topic: [Xen-devel] Xenoprof: getting Oprofile out of timer mode?
Xenoprof initialization is failing with -ENODEV status (-19).
There are two conditions that would cause this:
1) The local APIC is not available (cpu_has_apic is false)
2) OR the cpu (family/model) is not one of the known CPU models
   in xenoprof

Have you tried running Oprofile in vanila linux?
Does OProfile recognize the CPU model and the APIC in Linux?


> -----Original Message-----
> From: Ray Bryant [mailto:raybry@xxxxxxxxxxxxxxxxx] 
> Sent: Friday, May 19, 2006 3:04 PM
> To: xen-devel@xxxxxxxxxxxxxxxxxxx
> Cc: Andrei Lifchits; Santos, Jose Renato G; Gitika Aggarwal
> Subject: Re: [Xen-devel] Xenoprof: getting Oprofile out of timer mode?
> It's back!
> I'm trying to run xenoprof on an Intel VT platform (955 
> processor) under the latest xenbits unstable (well, when I 
> downloaded it last night, it was at changeset 10031, and I'm 
> getting the following when I run opcontrol:
> You cannot specify any performance counter events because 
> OProfile is in timer mode.
> The opreport command line in question is:
> opcontrol \
> --vmlinux=/home/raybry/xenbits-unstable.hg/linux-
/vmlinux \ --xen=/home/raybry/xenbits-unstable.hg/xen/xen-syms >
> --event=GLOBAL_POWER_EVENTS:100000:0:1:1
> The xen command line in /boot/grub/menu.lst includes the lapic option:
> title XENbits unstable xen
>     root (hd0,1)
>     kernel /boot/xen.gz lapic dom0_mem=512M tbuf_size=100 
> com1=115200,8n1
> console=com1 cdb=com1 sync_console
>     module /boot/vmlinuz-2.6.16-xen root=/dev/sda2 selinux=0 
> showopts psmouse.proto=bare lapic
>     module /boot/initrd-2.6.16-xen
> Attached is the xen.dmesg, the linux.dmesg, .config file for 
> the linux- kernel, and some system info.
> Any suggestions would be appreciated.
> --
> Ray Bryant
> AMD Performance Labs                   Austin, Tx
> 512-602-0038 (o)                 512-507-7807 (c)

Xen-devel mailing list