This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-devel] file corruption!!!

On 17 Jul 2004, at 16:25, Andy Isaacson wrote:

On Fri, Jul 16, 2004 at 04:06:20PM +1000, James Harper wrote:

I copied the file back from a known good source and restarted the
compile, but it aborted pretty quickly with internal gcc errors etc.

I then tried a basic file corruption test - copying large files of
known data back and forth lots and then finally compare to the
original but that started seg faulting, and then the process hung in a
'D' state, so i'm rebooting now.

When it comes back up i'll try to break it again.

Sounds like hardware failure.  Run memtest86 for an hour or so and let
us know whether it finds any errors.

Well, I also have similar corruption in my domain0 filesystems, and I've heard of another instance, so there could be something in this.

Running -unstable as of yesterday, but with v1.9 of linux-2.4.26-xen-sparse/arch/xen/drivers/blkif/backend/vbd.c, as the v1.11 changes seem to break exporting block devices from domain0. The filesystems are on devicemapper LVs, but copying to a file and exporting the loop device didn't help -- the xenU kernel reports 'no device' for /dev/sda1 when it tries to mount root. The same export statement worked when booting the kernel with earlier vbd.c.

I've just rebooted into a 2.6.6 kernel and fscked everything, and domain0's /usr needed plenty of repair. I'm going to let the machine chug for a bit in 2.6.6 and see if any problems show up. (The machine is remote, so I can't easily run memtest86.)

I also have a serial console problem - the console connection works fine with Linux 2.6, but appears to only work in one direction with Xen - I see the bios output, grub output, then Xen output, but once domain0 is booting I can't send characters, although ^A^A^A does switch between domain0 and Xen and I do see further console jibber.

I'm booting with this grub stanza:

title Xen Virtualised Linux
root (hd0,0)
kernel /boot/xen.gz dom0_mem=131072 com1=9600,8n1 watchdog console=com1,vga module /boot/vmlinuz-2.4.26-xen0 root=/dev/sda1 ro console=tty0 console=ttyS0,9600 panic=30


This SF.Net email is sponsored by BEA Weblogic Workshop
FREE Java Enterprise J2EE developer tools!
Get your free copy of BEA WebLogic Workshop 8.1 today.
Xen-devel mailing list