This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] segfault in dom0

To: xen-devel@xxxxxxxxxxxxxxxxxxxxx
Subject: [Xen-devel] segfault in dom0
From: Jody Belka <lists-xen@xxxxxxxx>
Date: Wed, 14 Jul 2004 23:54:57 +0000
Delivery-date: Thu, 15 Jul 2004 00:55:05 +0100
Envelope-to: steven.hand@xxxxxxxxxxxx
List-archive: <http://sourceforge.net/mailarchive/forum.php?forum=xen-devel>
List-help: <mailto:xen-devel-request@lists.sourceforge.net?subject=help>
List-id: List for Xen developers <xen-devel.lists.sourceforge.net>
List-post: <mailto:xen-devel@lists.sourceforge.net>
List-subscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=subscribe>
List-unsubscribe: <https://lists.sourceforge.net/lists/listinfo/xen-devel>, <mailto:xen-devel-request@lists.sourceforge.net?subject=unsubscribe>
Sender: xen-devel-admin@xxxxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.4i
Just finished copying 135 gigs of files into my dom0 system over
the network using smbclient. No errors occured during the copy.
Immediately afterwards i tried to run a find command, but it's
segfaulting on me:

<1>Unable to handle kernel NULL pointer dereference at virtual address 00000000
 printing eip:                                                                  
Oops: 0000             
CPU:    0 
EIP:    0819:[<c0037d86>]    Not tainted
EFLAGS: 00211213                        
eax: 00000000   ebx: fffffff0   ecx: 0000000d   edx: 00196f45
esi: 00000000   edi: c07fffa0   ebp: c07fff00   esp: c07ffee0
ds: 0821   es: 0821   ss: 0821                               
Process find (pid: 975, stackpage=c07ff000)<1>
Stack: c07fff50 00000000 c07fffa0 00000000 c1092758 c24bd000 00196f45 00000003 
       c07fff14 c002f571 c1d3aa40 c07fff50 c07fff50 c07fff5c c002fd40 c1d3aa40 
       c07fff50 00000000 c07fffa0 c24bd000 00000000 c278f8c0 0000000e c12c8974 
Call Trace: [<c002f571>] [<c002fd40>] [<c002ffed>] [<c003015e>] [<c00303cd>]   
   [<c002cf9a>] [<c009c08b>]                                                 

I've tried running find a few times, and the only differences each time
are in edi/ebp/esp/stackpage/stack/pid

I'm currently running rev 40f41ae00utn5d2f3tlNLcvG_QhiBA from 2004-07-13 

This also happened to me on an older rev, but i was messing about with the vmmon
stuff at the time, and i also wanted to move up to a newer rev to see if that
fixed things before saying anything. Now, last time the find worked again after
a reboot, but that's obviously no good. For the moment this time i've just left
things as-is right now.

Jody Belka
knew (at) pimb (dot) org

This SF.Net email is sponsored by BEA Weblogic Workshop
FREE Java Enterprise J2EE developer tools!
Get your free copy of BEA WebLogic Workshop 8.1 today.
Xen-devel mailing list