This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-API] XCP-1.1 cores-per-socket

To: xen-api@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-API] XCP-1.1 cores-per-socket
From: Sennaar <sennaar@xxxxxxxxx>
Date: Wed, 7 Sep 2011 17:10:34 +0400
Delivery-date: Wed, 07 Sep 2011 06:10:53 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; bh=U2+Mcki0Q//e5vrg4HFWXtucZh7f/hydfgULp/Hh+oo=; b=QCldak0qzPoKkjws/ZJRtTtjhXadxSvy3FK0U9ZDaO7b7xi9yrxC/hR4PCJ7QkgD6r 3QB7Pe4j05bDgULu4uQxah77j3SisRJvDRZYHPGfIcqFYqfw37zz9aij7/Mzn2CY0nSW lsWzDJ+KpiaZfUI5UrAOuhx/aB2VeKl4EVb20=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-api-request@lists.xensource.com?subject=help>
List-id: Discussion of API issues surrounding Xen <xen-api.lists.xensource.com>
List-post: <mailto:xen-api@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-api>, <mailto:xen-api-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-api>, <mailto:xen-api-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-api-bounces@xxxxxxxxxxxxxxxxxxx
Hi, I've been doing some 1.1 testing for sometime already, and now I'm stuck with platform:cores-per-socket option, which worked fine with previous versions.

VM is the default installation of Windows Server 2008 R2 + PV drivers 

[root@xen1 ~]# xe vm-param-get param-name=VCPUs-at-startup uuid=82f21a56-2891-a7cc-5529-21adfa6dc7e1
[root@xen1 ~]# xe vm-param-get param-name=VCPUs-max  uuid=82f21a56-2891-a7cc-5529-21adfa6dc7e1
[root@xen1 ~]# xe vm-param-get param-name=platform uuid=82f21a56-2891-a7cc-5529-21adfa6dc7e1 
cores-per-socket: 4; timeoffset: -25200; nx: true; acpi: true; apic: true; pae: true; viridian: true

When it starts it has only 4 active core, yet 12 cores in "Device Manager". I tried 2\3\4\6\12 binding --- nothing works.

Does it work in 1.1 at all?  

xen-api mailing list
<Prev in Thread] Current Thread [Next in Thread>