[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-users] Creating a Fedora 11 DomU

  • To: xen-users@xxxxxxxxxxxxxxxxxxx, Ian Murray <murrayie@xxxxxxxxxxx>
  • From: Boris Derzhavets <bderzhavets@xxxxxxxxx>
  • Date: Tue, 25 Aug 2009 08:22:44 -0700 (PDT)
  • Cc:
  • Delivery-date: Tue, 25 Aug 2009 08:23:38 -0700
  • Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=s1024; d=yahoo.com; h=Message-ID:X-YMail-OSG:Received:X-Mailer:Date:From:Subject:To:In-Reply-To:MIME-Version:Content-Type; b=5JXaIk4hinFp5pij62Cp0/y5mkE1tt/+7BnAc6F40mD7umMWvWj95q9dXf1T9eAmJCjsAB30npMV4D/H6TdongtC60KlBLVB8Hqn4s0s/6ytxQxGwpQ88NLn/kppszgfMZggsYdb+Li2k/49LMpo0cvgVn5Z4sSIrEpjVKjJ2Vw=;
  • List-id: Xen user discussion <xen-users.lists.xensource.com>

Install from local Apache Mirror provides all options.

# mount -o loop f11.iso /var/www/html/f11

Point virt-install or virt-manager to  --location http:/IP-Dom0:/f11



--- On Tue, 8/25/09, Ian Murray <murrayie@xxxxxxxxxxx> wrote:

From: Ian Murray <murrayie@xxxxxxxxxxx>
Subject: [Xen-users] Creating a Fedora 11 DomU
To: xen-users@xxxxxxxxxxxxxxxxxxx
Date: Tuesday, August 25, 2009, 9:33 AM

Hi All,

I just tried to create a DomU using the following method... (I normally use the Xen install kernel when I create CentOS domus, but when I tried that with the PXE image, that had the same effect as below). This is the first time I have created a Fedora domu in ages... years, even.

virt-install \
              --paravirt \
              --name demo \
              --ram 500 \
              --file /xen/demo.img \
              --file-size 6 \
              --nographics \
              --location http://mirror.ox.ac.uk/sites/download.fedora.redhat.com/pub/fedora/linux/releases/11/Fedora/x86_64/os/

Whilst it worked, I got no chance to set any packages and I ended up with a pretty empty domu, with no networking, etc. In fact, examining the console I don't get much in the way of output, compared to me CentOS domu's.

PCI: Fatal: No config space access function found
IO APIC resources could be not be allocated.
        Welcome to Fedora
        Press 'I' to enter interactive startup.
Starting udev: [  OK  ]
Setting hostname localhost.localdomain:  [  OK  ]
mdadm: No arrays found in config file or automatically
Setting up Logical Volume Management:   2 logical volume(s) in volume group "VolGroup" now active
[  OK  ]
Checking filesystems
Checking all file systems.
[/sbin/fsck.ext4 (1) -- /] fsck.ext4 -a /dev/mapper/VolGroup-lv_root
/dev/mapper/VolGroup-lv_root: clean, 17225/310688 files, 169285/1242112 blocks
[/sbin/fsck.ext3 (1) -- /boot] fsck.ext3 -a /dev/xvda1
/dev/xvda1: clean, 36/51200 files, 20599/204800 blocks
[  OK  ]
Remounting root filesystem in read-write mode:  [  OK  ]
Mounting local filesystems:  [  OK  ]
Enabling /etc/fstab swaps:  [  OK  ]
Entering non-interactive startup
ip6tables: Applying firewall rules: [  OK  ]
iptables: Applying firewall rules: [  OK  ]
Starting auditd: [  OK  ]
Starting system logger: [  OK  ]
Starting system message bus: [  OK  ]
Starting sshd: [  OK  ]
Starting exim: [  OK  ]
[  OK  ] crond: [  OK  ]

Fedora release 11 (Leonidas)
Kernel on an x86_64 (/dev/hvc0)

localhost.localdomain login:

I've had a quite a google and couldn't really figure out what I am doing wrong. I am sure I am doing something stupid, so please put me out of my misery. I think I have been living in a CentOS comfort zone for too long!

Thanks in advance,


Xen-users mailing list

Xen-users mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.