[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Xen 4.1 + PVOPS and Sandy Bridge integrated graphics

  • To: Konrad Rzeszutek Wilk <konrad.wilk@xxxxxxxxxx>
  • From: AP Xen <apxeng@xxxxxxxxx>
  • Date: Tue, 31 May 2011 12:05:42 -0700
  • Cc: xen-devel@xxxxxxxxxxxxxxxxxxx
  • Delivery-date: Tue, 31 May 2011 12:07:17 -0700
  • Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:in-reply-to:references:date:message-id:subject:from:to :cc:content-type:content-transfer-encoding; b=Bda/reUYmS4lSGQ1gbwC0TWTh2lSk1VZFeU1hTLx9XBVEsF37ajKBG2syaCNH6YFCA hvZroInW3ESzxQPzvNYeIiysPiLJC7HUz+YIDs4XkuGpyjK1juNLeuv0tG1NEUEpleF0 cABITCkH3TzJmjbTvXTsQ5r0Hi1ni7kkQSPDk=
  • List-id: Xen developer discussion <xen-devel.lists.xensource.com>

On Tue, May 31, 2011 at 6:59 AM, Konrad Rzeszutek Wilk
<konrad.wilk@xxxxxxxxxx> wrote:
> On Fri, May 27, 2011 at 03:32:37PM -0700, AP Xen wrote:
>> I am trying to get Xen 4.1 + Dom0 working on my Thinkpad
>> x220 which has the Sandybridge integrated graphic device. Everything
>> works except X does not come up. I am attaching the dom0 and xen boot,
>> Xorg log, lspci output and dom0 configuration that I used to build it.
> Great..
>> The only errors I am seeing are in the xorg logs:
> I would have expected some more details from the drm..
>> [    14.557] (EE) open /dev/fb0: No such file or directory
>> [    14.778] (EE) intel(0): No kernel modesetting driver detected.
>> [    14.778] (II) UnloadModule: "intel"
>> [    14.778] (EE) Screen(s) found, but none have a usable configuration.
>> [    14.778]
>> Fatal server error:
>> [    14.778] no screens found
>> [    14.778]
>> I checked out the XenPVOPSDRM wiki page and I have tried the various
>> suggestions mentioned there including "nomodeset". Have there been new
>> developments in this area? Are there new branches that I could try?
>> Thanks,
>> AP
> I was under the impression that SandyBridge support required
> kernel 2.6.37 or later..? The other issue is, do you have
> this in your git tree:
> commit 96587057018b3ac0b11bf34b791aaadfc403fc80
> Author: Zhang, Fengzhe <fengzhe.zhang@xxxxxxxxx>
> Date:   Wed Feb 16 22:26:20 2011 +0800

I do see this patch when I do "git log" and grep for the commit signature.

> Does Xorg work when you boot this kernel under baremetal?

I should have tried this before. No it does not. I see the same
errors. So you might be right in that I need a kernel > than 2.6.37.
Is there a tree out there that I can try? Or do I have to wait to for
Linux 3.0 to come out which I know can work as a Dom0 out of the box
without external patches?


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.