[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Xen-devel] PVOPS dom0 requires nomodeset to boot but video requires modesetting driver

Xen Users,

In trying to bring up a new machine, I have debugged to the point that it 
appears that nomodeset is required to boot a pvops dom0 on Xen 4.0.1, on this 
machine (otherwise a udevd failure), but the video will not work without KMS, 
i.e. dom0 gets a "No modesetting driver detected" error. Everything in dom0 
works fine remotely, including X forwarding, but no GUI on the console. I have 
tried all combinations of iommu, nomodeset, and nopat. I have also tried 
intel_iommu=igfx_off, without changing the results.

Any suggestions?


What is the formal meaning of the one-line program
#include "/dev/tty"

J.P. McDermott                  building 12
Code 5542                       mcdermott@xxxxxxxxxxxxxxxx
Naval Research Laboratory       voice: +1 202.404.8301
Washington, DC 20375, US        fax:   +1 202.404.7942

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.