[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [PATCH 06/14] libxl: disks: rename disk param "unpluggable" to "removable"

On Thu, 2011-05-12 at 15:36 +0100, Ian Jackson wrote:
> This property corresponds to what is called "removable" in xenstore,
> and is the conventional meaning of "removable": ie, the _media_ can be
> removed even as the _device_ remains present.
> "unpluggable" is a misleading name for this.
> Signed-off-by: Ian Jackson <ian.jackson@xxxxxxxxxxxxx>

Acked-by: Ian Campbell <ian.campbell@xxxxxxxxxx>

> diff --git a/tools/libxl/xl_cmdimpl.c b/tools/libxl/xl_cmdimpl.c
> index 28e810c..97a1241 100644
> --- a/tools/libxl/xl_cmdimpl.c
> +++ b/tools/libxl/xl_cmdimpl.c
> @@ -385,7 +385,7 @@ static void printf_info(int domid,
>          printf("\t\t\t(physpath %s)\n", d_config->disks[i].pdev_path);
>          printf("\t\t\t(phystype %d)\n", d_config->disks[i].backend);
>          printf("\t\t\t(virtpath %s)\n", d_config->disks[i].vdev);
> -        printf("\t\t\t(unpluggable %d)\n", d_config->disks[i].unpluggable);
> +        printf("\t\t\t(unpluggable %d)\n", d_config->disks[i].removable);
>          printf("\t\t\t(readwrite %d)\n", d_config->disks[i].readwrite);
>          printf("\t\t\t(is_cdrom %d)\n", d_config->disks[i].is_cdrom);
>          printf("\t\t)\n");

Does anybody actually use this thing? I find it hard to believe that it
is actually close enough to whatever it is suppose to mimic to be


Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.