[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] [patch] new version of find_domain_by_id() without reference count [0/6]

On 9/12/06 4:09 am, "Santos, Jose Renato G" <joserenato.santos@xxxxxx>

> I only did minor tests on x86-32. Xen and dom0 boots fine and I can
> create and destroy domains. But, no more exaustive tests were done. I
> carefully checked if I removed all put_domain() associated with each
> modified invocation of find_domain_by_id but mistakes are always
> possible. It would be good to put this to some more exhaustive tests
> before pushing it to the main tree. Waiting for post 3.0.4 release is
> strongly suggested.

It can't go in until RCU is merged and that won't happen for 3.0.4 anyway.

When you post these again after 3.0.4 (which I'm sure you'll have to do) I'd
actually like the names as follows:
 1. Rename find_domain_by_id() to get_domain_by_id().
 2. Call the new function find_domain_by_id().

This has the obvious disadvantage of an old/new name clash so we effectively
change semantics of an existing function. *But* the new names are better
imo: get_domain_by_id() more obviously pairs with put_domain(), and
find_domain_by_id_noref() is ugly and this rename allows us to drop the
_noref suffix unambiguously.

I'd be interested to know what this does for find/get_domain_by_id()
percentages in your network profiles.

 -- Keir

Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.