[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Xen-devel] Compilation problem

Steven Hand a écrit :
When compiling XEN 3.0.3 (KERNELS = linux-2.6-xen0 linux-2.6-xenU) with=

Linux kernel or
and with gcc 4.1, I stumble over the following compilation error:

make[3]: entrant dans le repertoire
CHK include/linux/version.h
CC [M] net/ipv4/netfilter/ip_conntrack_proto_tcp.o
In file included from net/ipv4/netfilter/ip_conntrack_proto_tcp.c:33:
include/net/tcp.h: In function tcp_skb_pcount:
include/net/tcp.h:555: error: struct skb_shared_info has no member
named tso_segs
include/net/tcp.h: In function tcp_skb_mss:
include/net/tcp.h:561: error: struct skb_shared_info has no member
named tso_size
make[6]: *** [net/ipv4/netfilter/ip_conntrack_proto_tcp.o] Erreur 1
make[5]: *** [net/ipv4/netfilter] Erreur 2
make[4]: *** [net/ipv4] Erreur 2
make[3]: *** [net] Erreur 2

The build normally patches all of the references to tso_segs and tso_size
with references to gso_segs and gso_size, see patches/linux- This will only happen for linux kernel versions that have appropriate subdirectories in the patches directory. Since you're building a random other kernel, the patching will not occur and you'll get your error.
Are you sure you see this issue with (which is the kernel
shipped with 3.0.3-0)?
You're right, this does not happen with kernel but For the former
the compilation generates vmlinuz.img. and -xenU files
but which I cannot start correctly (on this problem I sent a message that is in the digest vol22 issue 29). That was why I tried to compile the code with another
(earlier or later) kernel.

For kernel I could not (yet) catch the bootup messages, but Mats guessed that it might be due to the absence of the SATA driver (the HDD is SATA in my config)
that I checked on my host machine.

On that one (P4HT with Ubuntu 6.10, kernel, the SATA drivers
are located in /lib/modules/2.6.17-10-generic/kernel/drivers/scsi and there are

3w-9xxx.ko      fdomain.ko      pdc_adma.ko      sata_uli.ko
3w-xxxx.ko      gdth.ko         ppa.ko           sata_via.ko
aacraid         ide-scsi.ko     qla1280.ko       sata_vsc.ko
ahci.ko         imm.ko          qlogicfas408.ko  scsi_debug.ko
aic7xxx         initio.ko       raid_class.ko    scsi_mod.ko
aic7xxx_old.ko  ipr.ko          sas              scsi_transport_fc.ko
aic94xx         ips.ko          sata_mv.ko       scsi_transport_iscsi.ko
arcmsr          iscsi_tcp.ko    sata_nv.ko       scsi_transport_sas.ko
ata_piix.ko     libata.ko       sata_promise.ko  scsi_transport_spi.ko
atp870u.ko      lpfc            sata_qstor.ko    sd_mod.ko
BusLogic.ko     megaraid        sata_sil24.ko    sg.ko
ch.ko           megaraid.ko     sata_sil.ko      sr_mod.ko
dc395x.ko       osst.ko         sata_sis.ko      st.ko
dmx3191d.ko     pata_pcmcia.ko  sata_svw.ko      sym53c8xx_2
eata.ko         pcmcia          sata_sx4.ko      tmscsim.ko

An "lsmod |grep ata" gives me:

ata_piix     13828 6
libata         88984 1     ata_piix
scsi_mod     181424 3 sg,sd_mod,libata

so they're apparently loaded.

However, in /lib/modules/, there is no scsi directory and in
/lib/modules/ there are

osst.ko      scsi_transport_fc.ko   sd_mod.ko  sr_mod.ko
scsi_mod.ko  scsi_transport_spi.ko  sg.ko      st.ko

Do I miss something?
Might that be the solution, and how can I generate the drivers apparently missing (ata_piix.ko and libata)?

It appears to be the same error with kernel

Any advice?
Use, or create new patches against the later kernels; you can probably get some help from looking at the -unstable tree.



Xen-devel mailing list



Lists.xenproject.org is hosted with RackSpace, monitoring our
servers 24x7x365 and backed by RackSpace's Fanatical Support®.