This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-ia64-devel] name conflict(map_domain_page)

To: Isaku Yamahata <yamahata@xxxxxxxxxxxxx>, xen-ia64-devel@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-ia64-devel] name conflict(map_domain_page)
From: Akio Takebe <takebe_akio@xxxxxxxxxxxxxx>
Date: Mon, 30 Jan 2006 14:07:30 +0900
Delivery-date: Mon, 30 Jan 2006 05:18:17 +0000
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <20060130032929.GF20536@xxxxxxxxxxxxx>
List-help: <mailto:xen-ia64-devel-request@lists.xensource.com?subject=help>
List-id: Discussion of the ia64 port of Xen <xen-ia64-devel.lists.xensource.com>
List-post: <mailto:xen-ia64-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-ia64-devel>, <mailto:xen-ia64-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-ia64-devel>, <mailto:xen-ia64-devel-request@lists.xensource.com?subject=unsubscribe>
References: <20060130032929.GF20536@xxxxxxxxxxxxx>
Sender: xen-ia64-devel-bounces@xxxxxxxxxxxxxxxxxxx
Hi, Yamahata and all

I think good sugesstion.
Should map_new_domain0_page()  also be renamed?
How are alloc_xxxx?
(I'm also bad at naming...)

Best Regards,

Akio Takebe

>I found that name map_domain_page is defined in two places.
>one is defined in xen/include/xen/domain_page.h.
>another is defined in xen/arch/ia64/xen/domain.c.
>Luckily this name conflict doesn't cause problem for now.
>However this is a bad practice, so it should be fixed.
>The one in xen/include/xen/domain_page.h is used in xen commonly,
>so the one defined in xen/arch/ia64/xen/domain.c should be renamed.
>I propose following name changes.
>(Only the name map_domain_page() is conflicted, 
>For consistency others should also be changed.)
>map_new_domain_page()  -> assign_new_domain_page()
>map_domain_page()      -> assign_domain_page()
>map_domain_io_page()   -> assign_domain_io_page()
>I am bad at naming, I hope someone propose better names.
>Any suggenstions?
>Once new names are decided, I will make a patch.
>Or if no objections, I will go with above name.
>Xen-ia64-devel mailing list

Xen-ia64-devel mailing list

<Prev in Thread] Current Thread [Next in Thread>