This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Trouble with manual bridging on Xen3/CentOS 5

To: Teck Choon Giam <giamteckchoon@xxxxxxxxx>
Subject: Re: [Xen-users] Trouble with manual bridging on Xen3/CentOS 5
From: Digimer <linux@xxxxxxxxxxx>
Date: Sat, 30 Apr 2011 12:50:22 -0400
Cc: "xen-users@xxxxxxxxxxxxxxxxxxx" <xen-users@xxxxxxxxxxxxxxxxxxx>
Delivery-date: Sat, 30 Apr 2011 09:51:46 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
In-reply-to: <BANLkTimE1YDM86_rYj6PHWqgDyRa1gQoHw@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <4DBB36EA.2030202@xxxxxxxxxxx> <BANLkTimE1YDM86_rYj6PHWqgDyRa1gQoHw@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv: Gecko/20110428 Fedora/3.1.10-1.fc14 Thunderbird/3.1.10
On 04/29/2011 06:26 PM, Teck Choon Giam wrote:
> On Sat, Apr 30, 2011 at 6:08 AM, Digimer <linux@xxxxxxxxxxx> wrote:
>> Hi all,
>>  While trying to sort out/test some patches, I was told that it's best
>> to create bridges manually in
>> /etc/sysconfig/network-scripts/ifcfg-xenbr*. I did this, commented out
>> (network-script network-bridge) and restarted the network and Xen.
> Yes, using system network configuration will be better.  Which
> distribution is this?  CentOS/RHEL 5?
> You commented out (network-script network-bridge)?  If you are using
> system network configuration to configure your bridge, have you try
> the following instead of commented out?
> (network-script /bin/true)

That was the ticket. I was able to provision a new VM with two
interfaces, however, the vifs were at MTU 1500 so I still have work to
do. :)

>>  With the bridges manually in place, and no longer having 'pethX'
>> devices, I tried to provision a VM and it failed with:
>> ====
>> # virt-install --connect xen --name vm0002_pppoe --ram 2048 --arch
>> x86_64 --vcpus 1 --cpuset 1-7 --location
>> --os-type linux --os-variant rhel5.4 --disk
>> path=/dev/drbd_x4_vg0/vm0002_1 --network bridge=xenbr0 --network
>> bridge=xenbr2 --vnc --paravirt --debug
> brctl show outout?
> Is your manual ifcfg-xenbr0 a bridge to ifcfg-eth0 and ifcfg-xenbr2 a
> bridge to ifcfg-eth2?
> Where is your ifcfg-eth1 and ifcfg-xenbr1?  Normal network
> configuration will have ifcfg-eth* in order... ...

I use eth1 on the dom0's as storage-only interfaces. As such, they'll
never be used by a domU, so I don't bother bridging them.

> It is hard to tell what went wrong without seeing the following outputs:
> brctl show
> ifconfig
> ip link
> Thanks.
> Kindest regards,
> Giam Teck Choon

If I run into more problems, I'll be sure to include the output from
those. Thanks again, that /bin/true was the ticket. :)

E-Mail: digimer@xxxxxxxxxxx
AN!Whitepapers: http://alteeve.com
Node Assassin:  http://nodeassassin.org

Xen-users mailing list