This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Problem with Xen bridge on Debian Lenny

To: Xen List <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] Problem with Xen bridge on Debian Lenny
From: Antoine Benkemoun <antoine.benkemoun@xxxxxxxxx>
Date: Wed, 22 Apr 2009 11:43:36 +0200
Delivery-date: Wed, 22 Apr 2009 02:44:19 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:mime-version:received:date:message-id:subject :from:to:content-type; bh=D6JYmStkibnsVqigdlLReqHQCGtUEFmzl4bQcWsXmp0=; b=bfhGcT2xt252RJjvyK/pwAC/anGqS8isp0YPj2FK6vVypbdPsFA8Ue0UUpL9wMoI5m rlkTrvDhPnAxpbXv24pCzBExAwlovLsuuXZ4na1Qni+YWncx5RIkys/8pbE0Xu/hUgM6 PWMICpyjpiRDUzk9W5w6FsCUF6kuu44tP4Xtw=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=mime-version:date:message-id:subject:from:to:content-type; b=CVgVS6xb7B7KSuhaFzojfYrKBbh4H4OoR7pm3Al/lRIBbH7s7x0SAMwXykY4H1G1Nh yX3QD+Egt7oWZzfO8EBFPjA39mgNq0JT+AFfsybnaq/R6rS4LAHEBX5t50uYzgt9g33y 5qPwckCB/Hmv5hS8oOgrh86DCnc7Edx6f05Go=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Hello Xen-Users,

I am trying to make Xen work on Debian Lenny and I'm getting pretty desperate... I am trying to install Xen on a battery of Dell Optiplex's 755. I am using Debian Lenny because I am rather familiar with it and Debian Etch doesn't work (no network drivers and no CD-ROM drivers).

I have installed Xen many times on Debian Etch with binaries and source and it has worked wonderfully. But today's matter is quite different.

I have tried installing Xen 3.2.1 from Debian repos and Xen 3.3.1 from source. Both installs go smoothly. Yet the problem is the same on both.

Now the killer problem... When I boot into Xen everything works fine except... the networking. The interface that was recognized as eth0 when I was with Debian (no Xen) now become eth1 for some unknown reason. The line responsible for this is the following :

tpxen kernel: udev: renamed network interface eth0 to eth1

So in Xen I have eth1. I enabled (network-script network-bridge) as well as (vif-script vif-bridge). No bridge appears and no vif interfaces, no nothing except eth1 and lo.

My dom0 has network connectivity but when I start my VM they do not start correctly since Xen cannot find the bridge. When I do brctl show, the bridge does not appear either. Nothing about the bridge in the dmesg ou in the kernel messages.

There is something in the xend.log but I don't know what it means:

INFO (XendNetwork:114) Not recreating missing unmanaged network xenbr0

Could anyone help me out with this ?

Thank you very much in advance for your help,

Antoine Benkemoun
Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>