This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] export single partitions to xen 3.1.2 domU

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] export single partitions to xen 3.1.2 domU
From: Steven Timm <timm@xxxxxxxx>
Date: Tue, 21 Apr 2009 23:20:03 -0500 (CDT)
Delivery-date: Tue, 21 Apr 2009 21:22:33 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

I have some old xen instances which were installed under
Xen 3.1.0 with the following Disk configuration

disk = [ 'phy:LG0/LV11,sda1,w', 'phy:LG0/LV12,sda2,w','phy:LG0/LV13,sda3,w' ]

Each one of these is a single partition, with a single file system.

I am now trying to run redhat/centos/scientific linux 5.2 and convert
these old domU's over.

I run a lot of stuff on redhat/centos/scientific linux but
I have used the virt-manager to install all of them, and they are
all set up using the xvda type file system in which each exported
partition has got a partition table.
disk = [ "phy:/dev/LG0/LV0,xvda,w", "phy:/dev/LG0/LV16,xvdb,w" ]

Is there any way to mountt single partitions
 under the new software, if so, how?

I tried to export the three partitions above as xvda,xvdb, xvdc
and change the fstab and the grub information in domU accordingly,
no luck

I also tried to just do things as before with sda1,sda2,sda3,
also no luck.

In all cases  I get this error

mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!


I suppose I could move all existing file systems to new ones
of the new format but would really like to avoid that if I can.

Steve Timm

Steven C. Timm, Ph.D  (630) 840-8525
timm@xxxxxxxx  http://home.fnal.gov/~timm/
Fermilab Computing Division, Scientific Computing Facilities,
Grid Facilities Department, FermiGrid Services Group, Assistant Group Leader.

Xen-users mailing list