This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] qemu-dm vnc connection stuck on inactive connection

To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] qemu-dm vnc connection stuck on inactive connection
From: "Dustin Henning" <Dustin.Henning@xxxxxxxxxxx>
Date: Tue, 21 Apr 2009 09:26:24 -0400
Delivery-date: Tue, 21 Apr 2009 06:27:08 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Organization: PRD, Inc.
Reply-to: Dustin.Henning@xxxxxxxxxxx
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcnChMRF7cYvgWObTkuZ5ByXXZJHCA==
Let me start off by saying that I suspect the solution to my problem will be
embarrassingly simple and not wholly Xen related, and though I tried some
generic web searching I am especially terrible at searching to find things
that I haven't already seen in the past.  However, I do feel that the
solution will be a valuable thing to have in the xen-users archive.  Also,
because the problem is so basic, I doubt the solution will be distribution
specific, much less xen-version specific (I suspect that if the solution I
am looking for exists, it lies in a standard *nix utility), so I have
intentionally left out all version information.

That said, the problem follows:

I tried to VNC to one of my virtual machines using a ported vnc client on a
StrongARM device, and was unsuccessful.  I now can't VNC to that domU with
other computers either, as they queue up behind the device.

[virtadmin@virt1 ~]$ sudo netstat -np | grep 5901
tcp        0      0
tcp        0      0
ESTABLISHED 3712/qemu-dm
[virtadmin@virt1 ~]$

The client device at is not even active, and these connections
were both attempted over a week ago.  I am pretty sure killing qemu-dm =
killing the domU, so I don't want to do that.  I am also pretty sure
rebooting the domU would solve the problem, but I don't particularly want to
do that either.  Can anyone tell me if there is an easy way to terminate
these connections without terminating the process/domU?


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] qemu-dm vnc connection stuck on inactive connection, Dustin Henning <=