This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] I/O request not ready when VNC enabled

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] I/O request not ready when VNC enabled
From: daniel@xxxxxxxxxxxxxxx
Date: Thu, 9 Apr 2009 07:33:19 +0900 (EIT)
Delivery-date: Wed, 08 Apr 2009 15:34:03 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxxx
Importance: Normal
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: SquirrelMail/1.4.17
I have a headless CentOS 5.3 box running Xen 3.3.1. The DomU (domcont) is
running off a DRBD device and the network bridge (br0) is running over a
bonded ethernet link. All network interfaces are running fine and the DRBD
devices replicate over their respective links. The DRBD device that I am
trying to boot off is /dev/drbd1 and is set to Primary on the Dom0 that is
running this DomU.

The current configuration file for the DomU is as follows:

kernel = "/usr/lib/xen/boot/hvmloader"
builder = 'hvm'
memory = '4096'
name = "domcont"
vcpus = 3
vif = [ 'bridge=br0' ]
disk = [ 'phy:/dev/drbd1,hda,w'

The DomU can boot if vnc=0 in the DomUs configuration file but as soon as
I enable VNC it crashes with the following error in the qemu-dm log:

domid: 3
qemu: the number of cpus is 3
config qemu network with xen bridge for  tap3.0 br0
Watching /local/domain/0/device-model/3/logdirty/next-active
Watching /local/domain/0/device-model/3/command
qemu_map_cache_init nr_buckets = 10000 size 3145728
shared page at pfn efffe
buffered io page at pfn efffc
Time offset set 0
Register xen platform.
Done register platform.
medium change watch on `hdc' (index: 1): /mnt/images/2003SrvCD1.iso I/O
request not ready: 0, ptr: 0, port: 0, data: 0, count: 0, size: 0 I/O
request not ready: 0, ptr: 0, port: 0, data: 0, count: 0, size: 0 I/O
request not ready: 0, ptr: 0, port: 0, data: 0, count: 0, size: 0

When I run 'xm create domcont' as root with vnc=1 in the configuration
file the DomU immediately crashes and does not show when I run 'xm list'.

Thanks for your help in advance.


Daniel Davis

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>