This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] arp who-has packets not seen in Dom0 even by tcpdump

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] arp who-has packets not seen in Dom0 even by tcpdump
From: Литницкий Александр <litnialex@xxxxxxxxxxx>
Date: Mon, 31 Mar 2008 17:04:52 +0400
Delivery-date: Wed, 23 Apr 2008 05:53:59 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mozilla-Thunderbird (X11/20070828)
Hi all,
I'm running Xen-3.2 and linux-image-2.6.18 as Dom0 kernel on a VT-x processor. The problem is that broadcast arp who-has packets are not seen in Dom0 kernel. I've tried both precompiled debian kernel and compiled latest one from sources as described at http://lists.xensource.com/archives/html/xen-users/2008-01/msg00699.html

There is no linux bridge invoked, xend-config has (network-script network-dummy) There is no firewall invoked: iptables -vnL shows nothing, polices are ACCEPT. arptables is also empty. There are no DomU running. ( actually i've tested both hvmloader with knoppix liveCD and vanilla paravit_ops linux-2.24 kernel but it changes nothing regarding this issue) The temporary work-around was to add static arp entry at the router, but i really need to get arp-who has working!

Linux-running router  has vlan interface named breeze. I run
"arping -i breeze" and "tcpdump -nn -i breeze port \! 22 -e" shows:
16:31:03.725312 00:16:76:c5:a3:14 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 42: arp who-has tell 16:31:04.729177 00:16:76:c5:a3:14 > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 42: arp who-has tell

tcpdump on xen server shows nothing. If i plug the same cable from xen server into any other server - i can see those packets. When i boot xen server using usual linux kernel (not xenified ) - i see those packets. Ethernet card used in xen server is 04:00.0 Ethernet controller: Intel Corporation 80003ES2LAN Gigabit Ethernet Controller (Copper) (rev 01)
and e1000 driver is used.

In other direction arp is working ok. From Xen server:
breeze:~# tcpdump -nn -i lan1 -e arp
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on lan1, link-type EN10MB (Ethernet), capture size 96 bytes
16:35:27.082508 00:30:48:62:d3:4a > ff:ff:ff:ff:ff:ff, ethertype ARP (0x0806), length 42: arp who-has tell 16:35:27.083213 00:16:76:c5:a3:14 > 00:30:48:62:d3:4a, ethertype ARP (0x0806), length 60: arp reply is-at 00:16:76:c5:a3:14

Is it a bug in xen or e1000 driver? how can i debug it and what additional info can i provide?

Will be thankful for any tips, cause I'm really stuck with this issue for about a couple of days. Should i mention that i've already searched through all the web?

Best Regards,


Litnitchii Alexander
Information Security Engineer

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] arp who-has packets not seen in Dom0 even by tcpdump, Литницкий Александр <=