This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] OT: mounted img file read-only.

To: Xen List <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] OT: mounted img file read-only.
From: James Pifer <jep@xxxxxxxxxxxxxxxx>
Date: Fri, 18 Apr 2008 12:34:15 -0400
Delivery-date: Mon, 21 Apr 2008 09:28:05 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
So I've been converting Windows VMWare VM's to xen domU's using this
site as a guide:

I even took a MS VM, converted to VMWare, then to a domU and it worked. 

I have one PCI Device that is not being found on all the machines I've

Q1) I assume since these are full virtualization that I need the drivers
for the specific hardware?

I also had my first failed conversion. It fails in the steps replacing
the HAL version. When I mount the img file like:
mount -o loop,offset=$((63*512)),rw server.img /mnt

I can view the file system, but when I try to put the right HAL.dll in
place I get:
cp: cannot remove `/mnt/WINNT/system32/hal.dll': Read-only file system

Q2) Any ideas why this file system is Read-only? This is the same
procedure I've done on all my conversions. First 4 of them worked fine. 

Any help is appreciated. 


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>