This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Syntax for PCI Pass-Thru for multiple devices?

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Syntax for PCI Pass-Thru for multiple devices?
From: Daniel Kao <dkao@xxxxxxxxxxxx>
Date: Fri, 11 Apr 2008 17:27:01 -0700
Delivery-date: Fri, 11 Apr 2008 17:27:37 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <47FFFFFA.4070501@xxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <47FFF928.9090104@xxxxxxxxxxxx> <47FFFFFA.4070501@xxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Windows/20080213)
Hi Age_M,

I'll give it a try! Thanks! I thought about switching to single-quotes from double-quotes but haven't done it yet. The PCI devices are definitely IRQ sharing (IRQ's 21 and 22). I'll play around some more. Since at least one of them showed up in domU, I knew at least it was a good sign ;)

Thanks, again!


Age_M wrote:
Hi Daniel,

try this:

pci = [ '01:08.0','01:09.0' ]

If it still doesn't work, try using noirqdebug. I am not sure if you have to add it to your grub config or at the extra line in domU config but it resolves Problems with PCI devices sharing one IRQ. Maybe you just google it, to get the full information on this.

Good luck,

Daniel Kao wrote:
Hi All,

This might be a stupid question, but I have two PCI devices that I want to pass-thru to a PV domU. I can pass one of them, but not both. I'm sure it's a stupid syntax issue within my configuration file. When I do a "lspci" in the domU, (CentOS 5.1), only one of the devices shows up.

(e.g.) 00:00.0 Multimedia video controller: Internext Compression Inc iTVC16 (CX23416) MPEG-2 Encoder (rev 01)

The two devices are, (01:08.0) and (01:09.0) in dom0. If I do either of the following:

pci = [ "01:08.0" ] or pci = [ "01:09.1" ] in the configuration file, they'll show up.

I've tried:

pci = [ "01:08.0, 01:09.0" ]
pci = [ "01:08.0,01:09.0" ]
pci = [ "01:08.0", "01:09.0" ]
pci = [ "01:08.0","01:09.0" ]

No go on getting both passed. I'm sure I'm just doing something stupid with the syntax.

Any help would be appreciated!  Thanks!

P.S. Both devices are TV Tuner cards. I've verified the drivers for them in dom0 are not loaded/unbound and both devices exist in /sys/bus/pci/drivers/pciback/.
Daniel Kao, Übermind
Seattle, WA

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>