This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Sup guys, I'm a Xen noob, I have plenty of questions...

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Sup guys, I'm a Xen noob, I have plenty of questions...
From: trist007 <thartanian@xxxxxxxxxxx>
Date: Wed, 2 Apr 2008 07:00:43 -0700 (PDT)
Delivery-date: Wed, 02 Apr 2008 07:01:53 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
I'm running Fedora 8 on an E6300 OC'd to 2.5 GHZ, 2 gigs of DDR2 Ram, around
950GB on a raid0.  I have 2 main partitions, 600GB nfts for windows xp and
300GB ext3 for Fedora 8, and 2GB swap.  Anyhow, I use Fedora most of the
time.  So here is what I've done so far.  I yum installed kernel-xen xen and
virt-manager.  I rebooted to the xen os.  When I booted into the Desktop, I
noticed that my windows were all out of whack (I have compiz fusion
installed on my regular Fedora 8 OS).  So I deactivated desktop effects and
everything worked fine.  I noticed that my kmod-nvidia driver was no longer
installed.  Can you guys explain what this OS is?  It seems to be a
duplicated of my normal Fedora 8 OS but only that my nvidia driver isn't
loaded.  So, if I wanna run an OS and a virtual OS, I have to boot up to
this OS? the one with xen at the end?  I tried installing the kmod-nvidia
driver but it didn't install because it said that the kernel was already

Ok, so I used the gui virtual machine manager and created a virtual OS of
Fedora 7, I made it paravirtual, gave it 10GB, and 512MB of Ram, and created
a virtual network.  After it installed I could see the blue console.  Now
I'm a bit confused.  Is the Installation complete?  It never said that the
installation was complete, but nothing is happening.  What can I do with
this blue console?  How do I run programs on it?  I mess with the virtual
machine manager and see how my new virtual os is taking up cpu usage.  So I
rebooted the computer back to the original Fedora 8 OS.  I try using virtual
machine manager, but it won't connect, it says that my libvirtdaemon hasn't
started.  So I reboot to the Fedora 7 xen OS.  I go to virtual machine
manager and try to connect to my virtual os.  It starts up and it says it's
running, but there's no cpu usage.  I check the console, and it says it's
currently unavailable.  It won't let me pause the virtual os, says that the
POST operation failed, bootloader didn't return any data.  What do I need to
do to get the virtual os to start running again?

Much thanks for helping out guys.  I'm just confused.  I wanted to use a
virtual os to setup and ftp server, but I just don't see how one can do so
with that blue console.  I'm obviously missing something.  Should I have
gone virtual instead of paravirtual?  Also, I've heard that once I get the
virtual os running, I can switch between my regular Fedora 8 OS and my
virtual Fedora 7 OS with a simple click of the mouse.  Is this true with Xen
or should I use another virtualization program.  Also, I have the Vanderpool
Technology activated in the bios, fyi.  Also, can I have a virtual os of
windows xp?  Like where it had asked me about the installation media, if I
had provided windows xp media, would it have worked?  Also, how do I tie a
linux install dvd to nfs?  I know that in order to do this, I need to find
out where my dvd is mounted.  How do I find that out?  I've been going to
/dev and searching there, how do I know which one is for my dvd player? 
Would it be /dev/dr0/ /dev/sdc?  Anyhow, thanks.

I've been retrying the virtual os installation and a blue screen comes up
and asks me to put in the web server and fedora directory.  I've been using
but I guess I need another one.  Any of you guys have any media http links
to Fedora 7 or 8?
View this message in context: 
Sent from the Xen - User mailing list archive at Nabble.com.

Xen-users mailing list