This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Xen 3.1.0 / Centos 5.1 / Kernel Bug 1055 - I can reprod. it

To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] Xen 3.1.0 / Centos 5.1 / Kernel Bug 1055 - I can reprod. it any time
From: "Schober Walter" <Walter.Schober@xxxxxxxxx>
Date: Tue, 1 Apr 2008 14:01:32 +0200
Delivery-date: Tue, 01 Apr 2008 05:02:10 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AciT8CApA0xks7raTMutj6hg5h6mlA==
Thread-topic: Xen 3.1.0 / Centos 5.1 / Kernel Bug 1055 - I can reprod. it any time


8 GB RAM, HP DL360G5, 2 Core2Duo, 3,2GHz, CentOS 5.1, latest update, 2.6.18-53.1.14.el5xen, x86_64

-> PV guest (32 PAE) kernel crashes anytime it seems to use a lot of buffers. It crashes always on a large query to a Postres server, remotely connected via SSH tunnel, using Perl DBD::Pg and postgresql-8.1.11-1.el5_1.1.

I found:

and some others pointing to Xen Bug 1055. It seems no one followed that up yet. Maybe due to not reproducability?

So if anybody could tell me please, what I should do while crashing my domU, I could provide information for that Bug.

Needless to say, that I'd like to stay on some RPM kernel version. I tried Xen 3.1.0 from xensource, which worked perfectly. Drawback is that it is not working in the CentOS environment w/o major adaptations. And the main reason to go to the CentOS kernel was GFS, which we couldn't make it run on the Xen 3.1.0.

I can reproduce the kernel bug in any other DomU on that HP, but not on my 2GB RAM test machine in the office. Someting related to the 8 GB?

Any hint/help much appreciated ;-)


    BUG: unable to handle kernel NULL pointer dereference at virtual address 00000088
     printing eip:
    2cc5f000 -> *pde = 00000001:64188027
    2cf7f000 -> *pme = 00000001:633ad067
    29d5a000 -> *pte = 00000000:00000000
    Oops: 0000 [#1]
    last sysfs file: /block/ram0/range
    Modules linked in: ipv6 i2c_dev i2c_core nls_utf8 cifs xennet ib_iser rdma_cm ib_cm iw_cm ib_addr ib_local_sa ib_sa ib_mad ib_core iscsi_tcp libiscsi scsi_transport_iscsi scsi_mod dm_mirror dm_multipath dm_mod parport_pc lp parport pcspkr xenblk ext3 jbd ehci_hcd ohci_hcd uhci_hcd

    CPU:    0
    EIP:    0061:[<c0456c7d>]    Not tainted VLI
    EFLAGS: 00210206   (2.6.18-53.1.14.el5xen #1)
    EIP is at __handle_mm_fault+0x271/0x104e
    eax: 00000088   ebx: 00000000   ecx: 00000000   edx: f5416000
    esi: 00000088   edi: 00000000   ebp: c1000000   esp: ebb98e30
    ds: 007b   es: 007b   ss: 0069
    Process export.pl (pid: 1831, ti=ebb98000 task=c0fc0550 task.ti=ebb98000)
    Stack: 00000000 00000001 0b411a94 ecefe0cc ecec33c0 00000000 00000000 00000000
           00000000 00000000 00000000 ecf7f2d0 00000088 ebb98f28 00004000 003f44d2
           00000040 ebb98f28 00004000 c0406dd2 ebb98e90 00000088 ebb98ec0 c0406dad
    Call Trace:
     [<c0406dd2>] do_softirq+0x1c/0xae
     [<c0406dad>] do_IRQ+0xa5/0xae
     [<c059c36c>] sys_recvfrom+0xcf/0x137
     [<c0406dd2>] do_softirq+0x1c/0xae
     [<c0541911>] evtchn_do_upcall+0x64/0x9b
     [<c0405515>] hypervisor_callback+0x3d/0x48
     [<c045961b>] vma_adjust+0x1a9/0x387
     [<c05fe609>] do_page_fault+0x6d5/0xbd8
     [<c0459b81>] vma_merge+0xdb/0x15f
     [<c045a06f>] do_brk+0x13a/0x1dc
     [<c043f6fa>] audit_syscall_exit+0x2b8/0x2d4
     [<c05fdf34>] do_page_fault+0x0/0xbd8
     [<c04054d3>] error_code+0x2b/0x30
    Code: 89 f0 c1 e0 05 8d 44 05 00 e8 6c bb ff ff 8b 74 24 08 c1 ee 09 81 e6 f8 0f 00 00 01 f0 89 74 24 54 89 44 24 30 0f 84 71 0d 00 00 <8b> 38 8b 68 04 89 bc 24 e0 00 00 00 f6 84 24 e0 00 00 00 81 0f

    EIP: [<c0456c7d>] __handle_mm_fault+0x271/0x104e SS:ESP 0069:ebb98e30
     <0>Kernel panic - not syncing: Fatal exception

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] Xen 3.1.0 / Centos 5.1 / Kernel Bug 1055 - I can reprod. it any time, Schober Walter <=