This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-devel] Trying to use Xen PV drivers for Windows (Release 0.5.0)

To: James Harper <james.harper@xxxxxxxxxxxxxxxx>
Subject: [Xen-devel] Trying to use Xen PV drivers for Windows (Release 0.5.0)
From: Igor Chubin <igor@xxxxxxx>
Date: Sun, 23 Dec 2007 00:19:35 +0200
Cc: xen-devel <xen-devel@xxxxxxxxxxxxxxxxxxx>, xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Sat, 22 Dec 2007 14:19:16 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <AEC6C66638C05B468B556EA548C1A77D0131A5AA@trantor>
List-help: <mailto:xen-devel-request@lists.xensource.com?subject=help>
List-id: Xen developer discussion <xen-devel.lists.xensource.com>
List-post: <mailto:xen-devel@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-devel>, <mailto:xen-devel-request@lists.xensource.com?subject=unsubscribe>
References: <AEC6C66638C05B468B556EA548C1A77D0131A5AA@trantor>
Reply-to: Igor Chubin <igor@xxxxxxx>
Sender: xen-devel-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Mutt/1.5.16 (2007-06-11)

Hello James,

Thank you for you work, 
it'r really interesting and really useful.

No about my experiments and problems.

I have tried to install your drivers into Windows XP.
I have downloaded the drivers from [1], 
unzipped it and installed it as describe in 
the INSTALL.txt.

The installation process was exactly as you have described
in the INSTALL.txt file. No any errors.

After that I have modified boot.ini (added new boot variant
with the /gplpv key) and rebooted the system.

I have tried to boot using the second boot option in the boot menu
(/gplpv) and have got blue screen of death
(it appeared just after a second as a I have pressed enter in
the boot menu).

I have tried to boot using the first boot option in the boot menu
(without /gplpv). The system have booted without any problem.
After that I have tried to make hot block-attach to
the domain.

sudo lvcreate -n winpv -L 2G /dev/MAIN
sudo xm block-attach 13 phy:/dev/MAIN/winpv /dev/hdd w

(where 13 is the id of the windows domain)

Just after I issue the command Windows goes into blue screen of
death. There are the message on th screen:

Technical information:
*** STOP: .....

***    xenvbd.sys  - Address FC769C787 base at ....

You can take a look at the shot of the screen with the error here [2].

I have tried to change the domain configuration.
I played with acpi, apic and pae parameters.
Domain didn't want to boot in any combination except 


This one was used before I've started to change apic/acpi/pae
parameters. At least I've reverted back to it.

Also I have tried to disable CDROM in the pv domain.
Without success.

Thank you for your any ideas.
And once again thank you for you work

[1] http://www.meadowcourt.org/WindowsXenPV-0.5.0.zip
[2] http://xgu.ru/download/xenpvwindows.png


igor@cholpon:~$ sudo xm dmesg
 Xen version 3.1-1 (Debian 3.1.1-1) (waldi@xxxxxxxxxx) (gcc version 4.2.3 
20071014 (prerelease) (Debian 4.2.2-3)) Sat Oct 20 09:40:12
 UTC 2007
 Latest ChangeSet: unavailable

(XEN) Command line: dom0_mem=1024000
(XEN) Video information:
(XEN)  VGA is text mode 80x25, font 8x16
(XEN)  VBE/DDC methods: V2; EDID transfer time: 1 seconds
(XEN) Disc information:
(XEN)  Found 2 MBR signatures
(XEN)  Found 2 EDD information structures
(XEN) Xen-e820 RAM map:
(XEN)  0000000000000000 - 000000000009f000 (usable)
(XEN)  000000000009f800 - 00000000000a0000 (reserved)
(XEN)  00000000000f0000 - 0000000000100000 (reserved)
(XEN)  0000000000100000 - 00000000cfff0000 (usable)
(XEN)  00000000cfff0000 - 00000000cfff3000 (ACPI NVS)
(XEN)  00000000cfff3000 - 00000000d0000000 (ACPI data)
(XEN)  00000000d0000000 - 00000000e0000000 (reserved)
(XEN)  00000000f0000000 - 00000000f8000000 (reserved)
(XEN)  00000000fec00000 - 0000000100000000 (reserved)
(XEN)  0000000100000000 - 0000000130000000 (usable)
(XEN) System RAM: 4095MB (4193852kB)
(XEN) Xen heap: 9MB (10096kB)
(XEN) Domain heap initialised: DMA width 32 bits
(XEN) PAE enabled, limit: 16 GB
(XEN) Processor #0 15:3 APIC version 16
(XEN) Processor #1 15:3 APIC version 16
(XEN) IOAPIC[0]: apic_id 2, version 17, address 0xfec00000, GSI 0-23
(XEN) Enabling APIC mode:  Flat.  Using 1 I/O APICs
(XEN) Using scheduler: SMP Credit Scheduler (credit)
(XEN) Detected 3015.500 MHz processor.
(XEN) AMD SVM: ASIDs disabled. 
(XEN) HVM: SVM enabled
(XEN) CPU0: AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ stepping 03
(XEN) Mapping cpu 0 to node 255
(XEN) Booting processor 1/1 eip 90000
(XEN) Mapping cpu 1 to node 255
(XEN) AMD: Disabling C1 Clock Ramping Node #0
(XEN) AMD SVM: ASIDs disabled. 
(XEN) CPU1: AMD Athlon(tm) 64 X2 Dual Core Processor 6000+ stepping 03
(XEN) Total of 2 processors activated.
(XEN)  -> Using new ACK method
(XEN) ..MP-BIOS bug: 8254 timer not connected to IO-APIC
(XEN)  works.
(XEN) Platform timer overflows in 8589 jiffies.
(XEN) Platform timer is 25.000MHz HPET
(XEN) Brought up 2 CPUs
(XEN)  Xen  kernel: 32-bit, PAE, lsb
(XEN)  Dom0 kernel: 32-bit, PAE, lsb, paddr 0xc0100000 -> 0xc0396b54
(XEN)  Dom0 alloc.:   000000003e000000->000000003f000000 (251904 pages to be 
(XEN)  Loaded kernel: c0100000->c0396b54
(XEN)  Init. ramdisk: c0397000->c0dffe00
(XEN)  Phys-Mach map: c0e00000->c0efa000
(XEN)  Start info:    c0efa000->c0efa46c
(XEN)  Page tables:   c0efb000->c0f08000
(XEN)  Boot stack:    c0f08000->c0f09000
(XEN)  TOTAL:         c0000000->c1000000
(XEN)  ENTRY ADDRESS: c0100000
(XEN) Dom0 has maximum 2 VCPUs
(XEN) Initrd len 0xa68e00, start at 0xc0397000
(XEN) Scrubbing Free RAM: .............................done.
(XEN) Xen trace buffers: disabled
(XEN) Std. Loglevel: Errors and warnings
(XEN) Guest Loglevel: Nothing (Rate-limited: Errors and warnings)
(XEN) Xen is relinquishing VGA console.
(XEN) *** Serial input -> DOM0 (type 'CTRL-a' three times to switch input to 
(XEN) Freed 96kB init memory.
(XEN) ioapic_guest_write: apic=0, pin=2, old_irq=-1, new_irq=0
(XEN) ioapic_guest_write: old_entry=00010000, new_entry=000009f0
(XEN) ioapic_guest_write: Installing bogus unmasked IO-APIC entry!
(XEN) grant_table.c:264:d0 Bad flags (0) or dom (0). (expected dom 0)
(XEN) grant_table.c:264:d0 Bad flags (0) or dom (0). (expected dom 0)
(XEN) grant_table.c:264:d0 Bad flags (0) or dom (0). (expected dom 0)
(XEN) grant_table.c:264:d0 Bad flags (0) or dom (0). (expected dom 0)
(XEN) grant_table.c:264:d0 Bad flags (0) or dom (0). (expected dom 0)
(XEN) grant_table.c:264:d0 Bad flags (0) or dom (0). (expected dom 0)
(XEN) grant_table.c:264:d0 Bad flags (0) or dom (0). (expected dom 0)

igor@cholpon:~$ sudo xm info
host                   : cholpon
release                : 2.6.18-4-xen-686
version                : #1 SMP Thu May 10 03:24:35 UTC 2007
machine                : i686
nr_cpus                : 2
nr_nodes               : 1
sockets_per_node       : 1
cores_per_socket       : 2
threads_per_core       : 1
cpu_mhz                : 3015
hw_caps                : 
total_memory           : 4095
free_memory            : 2344
xen_major              : 3
xen_minor              : 1
xen_extra              : -1
xen_caps               : xen-3.0-x86_32p hvm-3.0-x86_32 hvm-3.0-x86_32p 
xen_scheduler          : credit
xen_pagesize           : 4096
platform_params        : virt_start=0xf5800000
xen_changeset          : unavailable
cc_compiler            : gcc version 4.2.3 20071014 (prerelease) (Debian 
cc_compile_by          : waldi
cc_compile_domain      : debian.org
cc_compile_date        : Sat Oct 20 09:40:12 UTC 2007
xend_config_format     : 4

igor@cholpon:~$ grep -v ^# /etc/xen/windowsxp-hvm | grep -xv ''
kernel = "hvmloader"
memory = 412
shadow_memory = 8
name = "windowsxp-hvm"
vif = [ 'type=ioemu, bridge=service0, mac=00:16:3e:03:00:c1' ]
disk = [ 'file:/xen/images/windowsxp-hvm.img,hda,w' ] # , 
'file:/Volumes/ISO/windows-xp-pro-sp2.iso,hdc:cdrom,r' ]
device_model = 'qemu-dm'

WBR, i.m.chubin

Xen-devel mailing list