This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] xen dom0 server freezes every one or two hours

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] xen dom0 server freezes every one or two hours
From: Dirk Hilmer <dirk@xxxxxxxxxxxxxxxx>
Date: Fri, 21 Dec 2007 15:21:26 +0100
Delivery-date: Fri, 21 Dec 2007 06:22:27 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <20071221121341.A967B36BC2@xxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <20071221121341.A967B36BC2@xxxxxxxxxxxxxxxxxxxxxxxxx>
Reply-to: dirk@xxxxxxxxxxxxxxxx
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20071220)
Sebastian Reitenbach schrieb:

Igor Chubin <igor@xxxxxxx> wrote:
On Do, Dez 20, 2007 at 04:35:50 +0100, Sebastian Reitenbach wrote:

I switched to a xen kernel on a HP DL 365, running openSUSE 10.3,
The HP DL 386 is a amd64 based machine.

I had to add a swiotlb=16 kernel parameter into grub.conf, to get the kernel running at all. I have 4 virtual hosts running on the machine, also openSUSE 10.3,
I have two physical interfaced bonded together, then I have 10 vlan interfaces on top of the bond0 interface. The vlan interfaces are each connected to
bridge, one bridge for every vlan. Each of the four machines has 10 eth interface, that are connected to each of the bridges. Further I have several phy: disks from SAN configured handed over to the virtual machines.

Setup and test of the hosts went fine, but when under load, then after
hour or two, the server just freezes.

from time to time I see messages like this in the
dom0 /var/log/messages:
blkback: ring-ref 4882, event-channel 15, protocol 1 (x86_64-abi)
blkback: ring-ref 4883, event-channel 16, protocol 1 (x86_64-abi)

Don't know, what the meaning of them is, as far as I could find out via googling, it must have sth. to do with networking.
one of my associates have said that he has similar problem.
Network hangs from time to time, and only in case when he uses virtual network configuration
with VLANs. He has tried to reproduce the error but without

The error appears in random fashion.
At least we can't find the cause of the problem.

Yes, he also reported that there were messages in the Xend log file
in the same time as network was hanging (approximately same as he
said; he didn't manage to find exact time):

blkback: ring-ref 9, event-channel 5, protocol 1 (x86_32-abi) blkback: ring-ref 8, event-channel 4, protocol 1 (unspecified, assuming
native) at least I haven't yet recognized a hanging network. I just saw these messages, and thought it might be related to the more serious freezes theat I encounter every some hours. But I'll take a look in the xen log files when these messages appear again. thanks for pointing out.


further, on startup of the dom0, I see the following
in /var/log/boot.msg,
don't know whether this is a problem:

Starting udevd done
Loading required kernel modules
doneActivating swap-devices in /etc/fstab...
donemount: according to mtab, /dev/cciss/c0d0p1 is already mounted on /

NOTE: scsidev is obsolete and the udev generated persistent device names
 under /dev/scsi/by-id/ (od by-path) should be used instead.
Scanning SCSI devices and filling /dev/scsi/ done
Activating device mapper...
Creating multipath targets:device-mapper: create ioctl failed: Device or resource busy
device-mapper: create ioctl failed: Device or resource busy
device-mapper: create ioctl failed: Device or resource busy
device-mapper: create ioctl failed: Device or resource busy

The dom0 is started this way from GRUB:
# Modified by YaST2. Last modification on Fri Dec 14 15:03:43 CET 2007
default 0
timeout 8
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: xen###
title XEN -- openSUSE 10.3 -
    root (hd0,0)
    kernel /boot/xen.gz dom0_mem=390M
module /boot/vmlinuz- root=/dev/disk/by-id/cciss-3600508b1001030343620202020200001-part1
resume=/dev/cciss/c0d0p5 splash=silent showopts swiotlb=16
    module /boot/initrd-

uname -a
Linux srv4 #1 SMP 2007/11/19 15:02:58 UTC x86_64
x86_64 GNU/Linux

rpm -qa | grep xen

I also had powersaved stopped, acpi stopped, ntp stopped (I found a
where someone had
a problem with clocks walking backward and dying xen server), but so
the box still freezes
without any notice in the logs.

Any idea what could be the problem I have or where should I take a
look to figure out what causes the problem of the freezing server?

kind regards

Xen-users mailing list
WBR, i.m.chubin

Xen-users mailing list


same problem here and it can be reproduced. I use Gentoo 2007.0 with Xen 3.1.2 and kernel 2.6.22 (xen-sources) in 64bit mode.
The Server is a Dual Opteron 275 running in PV mode.
The Dom0 freezes every time if you generate system high-load, for example starting a boinc-client or doing big filesystem transfers.
-> Network hangs, SATA Devices time out

Normally the system freezes every 2 hours.
I tried to play with the Xen version compatibility in the kernel, but that doesn't make a difference.

Due to the HDD timeout I can't find anything in the logs...

kind regards


Xen-users mailing list