This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Ubuntu guest domain on Fedora host (dom0) domain

To: Stephan Seitz <s.seitz@xxxxxxxxxxxx>
Subject: Re: [Xen-users] Ubuntu guest domain on Fedora host (dom0) domain
From: Julius Spencer <jspencer@xxxxxxxxxxxxxxxxxxx>
Date: Tue, 18 Dec 2007 07:46:22 +1300
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Mon, 17 Dec 2007 10:46:38 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <4765DFFC.5040803@xxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <E8903E1D-CA1F-484A-BBDC-3E4CFB741496@xxxxxxxxxxxxxxxxxxx> <4765DFFC.5040803@xxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thank you for the reply.

I'm trying to install Ubuntu server as a guest on a Fedora host domain

I don't understand the functions of the guest's initrd and the guest's
kernel well enough to know which kernel I should be using. Should I use
the Fedora based domU kernel (which matches the dom0 one) or Ubuntu's

If I install using debootstrap would I need to swap out the kernel
provided with an Ubuntu one which has been xenified?

Not neccessarily, if your fine with the fedora kernel, just copy
dom0's /lib/modules/`uname -r` into the domU image.

I tried this first (using the fedora kernels and got this:

device-mapper: ioctl: 4.11.0-ioctl (2006-10-12) initialised:
md: md1 stopped.
Kernel panic - not syncing: Attempted to kill init!

Does this mean it is trying to find the disk but can't find it?

I assume Ubuntu would run on fedora kernel. If you want to keep your domU
distro "clean", then I would suggest to
- copy domU's kernel and initrd at some place in dom0

then I tried using an ubuntu xen kernel (putting it in the /boot dir of
the dom0 and chaging my config file) and got this:

[45911.512633] blkfront: sda1: barriers enabled
[45911.518792] netfront: device eth0 has copying receive path.
[45911.608257] Freeing unused kernel memory: 200k freed
[45911.810711] AppArmor: AppArmor initialized<5>audit(1197876779.830:2): 
type=1505 info="AppArmor initialized" pid=990
[45911.818980] fuse init (API version 7.8)
[45911.825888] Failure registering capabilities with primary security module.
[45911.860654] thermal: Unknown symbol acpi_processor_set_thermal_limit
[45911.876324] device-mapper: ioctl: 4.11.0-ioctl (2006-10-12)
initialised: dm-devel@xxxxxxxxxx

At this stage it just stops. I have to use Ctrl ] to get out of the
console. I'm not sure what would come next, but nothing happens.

- keep it in domU and use pygrub

I'm not sure how to do this yet so I haven't atempted it.

If you decide to use the recent ubuntu -xen kernel, disable the hwclock*
init scripts in domU and add

extra = 'xencons=tty'

to your domU cfg file, as the ubuntu kernel defaults to xvc0.


Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>