This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] DomU, PXE & Ubuntu Gutsy 64

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] DomU, PXE & Ubuntu Gutsy 64
From: Jinn <xen@xxxxxxxxxxxxxxxxx>
Date: Thu, 6 Dec 2007 17:47:12 +0100
Delivery-date: Thu, 06 Dec 2007 08:48:04 -0800
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx

I'm trying to get a DomU to PXE boot and install over the network. I have googled and search the mailing lists, and the limited info that exists doesn't appear to work.

I've installed an Ubuntu Gutsy 64 server environment. The system boots with the amd64 xen-enabled kernel and I have the stock Gutsy Xen-3.1 installed.

I have installed vtun and etherboot as I thought they may be dependancies for later attempts, but let me start at the beginning first.

I'm using LVM backed storage and have tried various configs. I first created my config using:

xen-create-image --size=60Gb --swap=4Gb --dhcp --lvm=vgXenU -- hostname=vm1 --fs=ext3 --image=full --kernel=/boot/vmlinuz-2.6.22-14- xen --memory=1G --no-install

I then edited the config and set it to network boot like this:

        boot        = 'n'
        memory      = '1024'
        root        = '/dev/sda1 ro'
disk = [ 'phy:vgXenU/vm1-disk,sda1,w', 'phy:vgXenU/vm1- swap,sda2,w' ]
        name        = 'vm1'
        dhcp        = 'dhcp'
        vif         = [ 'mac=00:00:00:00:00:AA' ]
        on_poweroff = 'destroy'
        on_reboot   = 'restart'
        on_crash    = 'restart'

xm create -c vm1.cfg returns:

        Using config file "./vm1.cfg".
        Error: Boot loader didn't return any data!

After a little debugging I decided this isn't working and I'm not sure how to debug it, so I decided I would try to boot an etherboot cd image (which I believe the boot=n should already be doing, but I couldn't find any images within any of the installed packages).

The etherboot config I'm trying is:

        boot        = 'd'
        builder     = 'hvm'
        memory      = '1024'
        root        = '/dev/sda1 ro'
disk = [ 'phy:vgXenU/vm1-disk,sda1,w', 'phy:vgXenU/vm1- swap,sda2,w', 'file:/boot/eb-rtl8139.iso,ioemu:hdc:cdrom,r' ]
        name        = 'vm1'
        dhcp        = 'dhcp'
        vif         = [ 'mac=00:00:00:00:00:AA' ]
        on_poweroff = 'destroy'
        on_reboot   = 'restart'
        on_crash    = 'restart'
        sdl = 0
        vnc = 1
        vncdisplay = 1
        vncunused = 0
        vncviewer = 0

Unfortunately this doesn't work either. I have also tried moving the CD definition to it's own attribute as follows - also with the same result.
        cdrom = 'file:/boot/eb-rtl8139.iso,ioemu:hdc:cdrom,r'

Since I've set an hvm builder I believe I should use VNC to connect due to the console. Is this correct? I was lead to this conclusion from the message "xenconsole: Could not read tty from store: No such file or directory" when using the "-c" option on starting the domU. I've tried various combinations of the VNC settings without luck.

In my attempts to debug this I found "xm list -ll | grep -i vnc" may provide some info. All it tells me is that VNC is configured, but not listening on any port:

# xm list -ll | grep -i vnc
            (vnc 1)
            (vncdisplay 1)
            (vncunused 0)
            (vncunused 0)
            (vncdisplay 1)

# netstat -ant | grep LISTEN
tcp 0 0* LISTEN tcp6 0 0 :::22 :::* LISTEN

It also appears from the xm list output that the new domain is doing nothing: Name ID Mem VCPUs State Time(s) Domain-0 0 2976 2 r----- 48.6 vm1 6 1024 1 ------ 0.0

"tcpdump -i eth0 ! port 22"  shows no traffic with the either attempt.

I am a bit lost at this point and don't know how to proceed. Any help would be appreciated and if necessary I'm happy to gather debugging info to get this working.

Thanks in advance,

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>