This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Xen 3 not seeing the right amount of RAM on x86_64

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Xen 3 not seeing the right amount of RAM on x86_64
From: "Chuck McIntyre" <chuck.mcintyre@xxxxxxxxx>
Date: Mon, 3 Dec 2007 10:15:21 -0800
Delivery-date: Mon, 03 Dec 2007 10:16:27 -0800
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=gamma; h=domainkey-signature:received:received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; bh=zB9Xa4nBnJOliTp9dNVQtQSDT/wB1HAyjYSUoLmP+L4=; b=pRNRiepidkWZddIGiNb3WZ2RdB4E1O5cjhwuRO2NXBoPgpvngtROzK5+ol8+CPC2Bb2Kb8pYeGPVYK6/fz9pu9Z5f8VIqXZeMhTkvgETq8VjHzqBVKilhLZaURjfHujmiTt3FIQeK3BPzhiJvokS7t26cTOiugPEtf2tXyrlXmU=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=gamma; h=received:message-id:date:from:to:subject:in-reply-to:mime-version:content-type:content-transfer-encoding:content-disposition:references; b=LNTjPE+lqJvTcQNgNOU2ppA47ML4Wz16wFHljcZbI1FRsyyR9f/jLRSVE5vDgIAM+UhfdCRQKOnzIVurLmVn1FIDwYjw+8OwLYlVTBTEuj3BIOa94TMLsGAqxhAVH3oep55mZQZMQVs5HXlgTxvcMwpnz7p6GFItQ3R96JalOwA=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <20071130210750.GA8436@xxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <b62bf9fa0711272047u725626bag78a365f4861833d2@xxxxxxxxxxxxxx> <200711280324.03841.dancab@xxxxxxxxxxxx> <b62bf9fa0711280413r2f398437m1113282943e9fc82@xxxxxxxxxxxxxx> <20071128132432.GA5017@xxxxxxxxxxxxxxxx> <b62bf9fa0711281041t4f91f681vab50f4e89e87ad8d@xxxxxxxxxxxxxx> <20071129100919.GA4400@xxxxxxxxxxxxxxxx> <b62bf9fa0711301140i1d71cc6bs538af801798885d3@xxxxxxxxxxxxxx> <20071130210750.GA8436@xxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Hi folks,

Just a quick update to this issue, which seems to be resolved (will
send out more information once we've tried the solution on other
systems as well). Originally we were running the following Xen


But were unable to see the correct RAM within Xen (3.5GB on a 4GB
system, for example) on 64bit CentOS linux with hardware
virtualization via the AMD Opteron 2200 chipset.

It was suggested that we try patching grub or upgrading to grub2,
since Xen appears to get its memory information from grub, it was also
suggested we try running the latest Xen.

As a first step we grabbed xen 3.1.2-pre and applied it to one of the
4GB systems. Suddenly everything worked!

[root@bouncingbetty ~]# uname -a
Linux bouncingbetty.mydomain 2.6.18-xen #1 SMP Fri Nov 30 17:48:44 PST
2007 x86_64 x86_64 x86_64 GNU/Linux
[root@bouncingbetty ~]# xm info | grep -i total_memory
total_memory           : 4095
>From xm top:
Mem: 4193844k total, 4190068k used, 3776k free    CPUs: 4 @ 2200MHz

We are going to try to apply this to one of our 8GB systems today, to
see if this fixes systems across the board.

As an added bonus, this seems to have also fixed the time/ntp issues
we were having in hardware virtualized linux.

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>