This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Re: Error: (9, 'Bad file descriptor')

To: "Xen Users" <Xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] Re: Error: (9, 'Bad file descriptor')
From: "Anand Gupta" <xen.mails@xxxxxxxxx>
Date: Thu, 1 Nov 2007 01:21:31 +0530
Cc: Fedora Xen <fedora-xen@xxxxxxxxxx>
Delivery-date: Wed, 31 Oct 2007 12:52:23 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=beta; h=domainkey-signature:received:received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:references; bh=KM5kDqfltYadsDWwuZ3AWLnP9dyWpeIf4rfLuyVrLfU=; b=R9U+7FBYvuABrFWLC/Qqjtzeb47/EAGYzkzCKRVSAyyv67/I9aB3yZeIrp5EZrKa+uTieuDJcPxord2h/A6/fpffvzwao2xvDfIK0/NiOQmsBWrDcx6QvokTyZYRJmbW6MNjpVebmDuS5BMQDMm46MDaw6A5usRi8Zdetv846pE=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:to:subject:cc:in-reply-to:mime-version:content-type:references; b=P8QrylYeWx7Vd89FrOCFbZ3VcG/VYVHM952nRtVxoGosk4iSuPW5/CnOTJJN4Doejnzr2EM6QwdDRJkg2icm4Y31DgM3Llf5tM5wxWiywBggRy7xWF85HbTW45BLX/GHLeuYjDxbb8zChMxVt3T8/pttfb6J79LiXiW2H4GKiT4=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <acb757c00710311237se2d0b45r60ad8c8f835995f5@xxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <acb757c00710311237se2d0b45r60ad8c8f835995f5@xxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
I also created a fresh domU using the wiki article located at http://wiki.centos.org/HowTos/Xen/InstallingCentOSDomU

After this since i have to use lvm, i created a new lvm volume, mounted the file, copied the first partition contents to the lvm volume. Now when i try to boot the lvm volume, it gives me the below error

mount: could not find filesystem '/dev/root'
Setting up other filesystems.
Setting up new root fs
setuproot: moving /dev failed: No such file or directory
no fstab.sys, mounting internal defaults
setuproot: error mounting /proc: No such file or directory
setuproot: error mounting /sys: No such file or directory
Switching to new root and running init.
unmounting old /dev
unmounting old /proc
unmounting old /sys
switchroot: mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

Here is the config file

name = "new2"
memory = "512"
disk = [ 'phy:/dev/VolGroup00/new2,xvda1,w',]
vif = [ 'bridge=xenbr0', ]
In the above i tried both xvda and xvda1, they give the same error.

/etc/fstab inside the lvm volume

/dev/xvda1              /                       ext3    defaults        1 1
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
tmpfs                   /dev/shm                tmpfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
sysfs                   /sys                    sysfs   defaults        0 0

Any pointers / ideas on how to fix the problems will be appreciated.


Anand Gupta
Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>