This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] mini-os.elf not created after "make"

To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] mini-os.elf not created after "make"
From: "Alasdair P Mclean" <mcleanap@xxxxxxxxxxxxx>
Date: Wed, 31 Oct 2007 14:04:26 -0000
Delivery-date: Wed, 31 Oct 2007 07:05:19 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
Thread-index: AcgbxvKxPd6hAZXqSiCOkA6/lh3iYg==
Thread-topic: mini-os.elf not created after "make"

Hey guys, having a problem getting Mini-os to run on xen.

Using a Scientific Linux 4.1 dom0, I type "make" in the extras/mini-os directory which creates the domain_config file, mini-os.gz file and several .o files. However no mini-os.elf file (that the domain_config says is the Kernel) is created, and so running xm with that config fails.

I've tried using gcc3 and gcc4, and (rather naively) even tried pointing the domain_config to mini-os.gz which unsurprisingly didn't work. Is there something I'm missing?


Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] mini-os.elf not created after "make", Alasdair P Mclean <=