This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Desperate :( DomU with kernel in Dom0

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: [Xen-users] Desperate :( DomU with kernel in Dom0
From: "Robin W. Muller" <robin@xxxxxxxxxxx>
Date: Sat, 27 Oct 2007 18:16:48 -0400
Delivery-date: Sat, 27 Oct 2007 15:18:44 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Macintosh/20070728)
Hello, maybe I'm stupid but I find no way to have the kernel in Dom0 instead of DomU for Centos 5.

Here is what I did:
Regular Centos 5 Dom0 install, then creating a LVM group (vms) and install DomU with virt-install works perfectly:
virt-install --p --location=http://mirrors.kernel.org/centos/5/os/i386 --file=/dev/vms/centos5_data --name=centos5 --ram=512 --nographics

I get a working domU but the config file has no kernel or ramdisk parameter and the kernel seems to be inside DomU

I created my own cfg then, using this parameter:

kernel      = '/boot/vmlinuz'
ramdisk     = '/boot/initrd.img'
root        = '/dev/xvda ro'
name = "centos"
memory = "512"
disk = [ 'phy:/dev/vms/centos_data,xvda,w', 'phy:/dev/vms/centos_swap,xvdb,w',]
vif = [ 'mac=00:64:18:20:52:07, bridge=xenbr0', ]
vcpus = 1

on_reboot   = 'restart'
on_crash    = 'restart'

For vmlinuz I tried a copy of Dom0's kernel, the kernel copied from inside the DomU as well as the downloaded kernel file from here:

For initrd.img I tried
a copy of Dom0's ramdisk, the ramdisk copied from inside the DomU as well as the downloaded ramdisk file from kernel.org.
I even tried building a ramdisk with:

/sbin/mkinitrd /boot/initrd.img 2.6.18-8.el5xen --with=netfront --with=blkfront  --with=sd_mod --with=scsi_mod

Nothing helps, the result is always:

mount: could not find filesystem '/dev/root'


switchroot: mount failed: No such file or directory

...well not always, if I use the ramdisk downloaded from kernel.org, I get a installation procedure (asking for language, skip media check and so on).

What have I done wrong?

Thank you very much for any help here!

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>