This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] xfs problems with xen3.1 on domu

To: Luciano Rocha <strange@xxxxxxxxxxxxx>
Subject: Re: [Xen-users] xfs problems with xen3.1 on domu
From: John McMonagle <johnm@xxxxxxxxxxx>
Date: Tue, 23 Oct 2007 16:53:17 -0500
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Tue, 23 Oct 2007 14:54:10 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <20071023171150.GA11377@xxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <471E17BC.8000000@xxxxxxxxxxx> <20071023171150.GA11377@xxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20070718)
Luciano Rocha wrote:
On Tue, Oct 23, 2007 at 10:48:12AM -0500, John McMonagle wrote:
 Have amd64 xen 3.1 installed on debian etch.

 Have all the domu file systems in lvm.

 Problem 1

 If I have a xfs files system when I mount it on domu I get this error:
Filesystem "sda5": Disabling barriers, not supported by the underlying device
 XFS mounting filesystem sda5
 Ending clean XFS mount for filesystem: sda5

 If I mount with nobarriers the message goes away.
 If I mount under dom0 there is no error message.
 Same if under 32 or 64 bit.

My guess is it's confused by the sda5 and expect some disk drive properties that do not exist.
 I'm new to xfs. Possibly this is not important??


It's not serious, but you can have problems on power-losses.

Just noticed that it is happening on dom0 also. Saw it on serial console.
It's "hardware" raid but it looks like write cache is disabled.
sginfo -c /dev/sda
Caching mode page (0x8)
Initiator Control                  0
ABPF                               0
CAP                                0
DISC                               0
SIZE                               0
Write Cache Enabled                0
MF                                 0
Read Cache Disabled                0
Demand Read Retention Priority     0
Demand Write Retention Priority    0
Disable Pre-fetch Transfer Length  0
Minimum Pre-fetch                  0
Maximum Pre-fetch                  0
Maximum Pre-fetch Ceiling          0
FSW                                0
LBCSS                              1
DRA                                0
NV_DIS                             0
Number of Cache Segments           0
Cache Segment size                 128
Non-Cache Segment size             0

They seem to recommend nobarrrier on hardware raid so maybe this is the correct setting.

 Problem 2

 If I run a 32 bit domu with a 64 bit kernel quota does not work
 root@nfondy:~# quota root
 Segmentation fault
 root@nfondy:~# xfs_quota
 xfs_quota> df
 XFS_IOC_FSGEOMETRY_V1: Invalid argument
 XFS_IOC_FSGEOMETRY_V1: Invalid argument
 XFS_IOC_FSGEOMETRY_V1: Invalid argument
 XFS_IOC_FSGEOMETRY_V1: Invalid argument
 XFS_IOC_FSGEOMETRY_V1: Invalid argument
 XFS_IOC_FSGEOMETRY_V1: Invalid argument

Yes, this is a bug removed in recent kernels.
I tried debian 2.6.18-5 kernel and tried kernel from xen binary distribution. Both are the same.
If I load the 64 bit executables and needed libraries at least it appears to work properly:
 root@nfondy:~# ./quota root
 Disk quotas for user root (uid 0): none
 root@nfondy:~# ./xfs_quota
 xfs_quota> df
 Filesystem           1K-blocks       Used  Available  Use% Pathname
 /dev/sda2              1038336     120160     918176   12% /
 /dev/sda2              1038336     120160     918176   12% /dev/.static/dev
 /dev/sda3              3135488    1022968    2112520   33% /var
 /dev/sda4              5232640    2004076    3228564   39% /usr
 /dev/sda5              1038336      18056    1020280    2% /home
 /dev/sda6              3135488        308    3135180    1% /tmp

 To me looks more like a mixed environment problem?
 In this case don't want to go 64 bit yet also need quota.
 Can one run a 32 bit xen kernel under 64 bit dom0?

Yes, on Xen >= 3.1.
Was not working but I tried 32 bit kernel from the xen 3.1 binary distribution and now 32 bit domu works.
It would be nice if they didn't name all the kernels the same.
It took a little ingenuity to build an initrd.
Is this a good solution?


John McMonagle
IT Manager
Advocap Inc.

Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>