This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Xen with LVM

To: xen-users@xxxxxxxxxxxxxxxxxxx
Subject: Re: [Xen-users] Xen with LVM
From: "IDAGroup - R.W.Muller" <robin@xxxxxxxxxxx>
Date: Thu, 11 Oct 2007 15:35:22 -0400
Delivery-date: Thu, 11 Oct 2007 12:36:42 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <470E692E.2090708@xxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <470E692E.2090708@xxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Macintosh/20070728)
Ok, I guess it has not really something to do with LVM, cause I just installed a (working!)
Centos5 guest into a (also working) Centos5 dom0 as imagefile. When I try to mount the image
I get:

[root@serv106 ~]# mount -o loop /disk.img /mnt/loop/
mount: you must specify the filesystem type

So, very similar to the error before (actually the same). What is wrong with my guest installation
that those are booting fine, but are not mountable?

Thanks for any help here,

IDAGroup - R.W.Muller wrote:
Hello everybody, new in the Country (coming from Switzerland) and new to Xen as well :)

I tried to install the first CentOS 5.0 - XEN -LVM machine but struggle somehow. I followed
the explanations of
Paul, but CentOS 5 seems to have a problem with mounting the LVM after installation:


When I create a new lv named centos5 and do a  mke2fs /dev/vm-data/centos5
I can easily mount the "drive" with mount /dev/vm-data/centos5 /mnt/centos5. I unmounted centos5 then
and started the virt-install. Said for path /dev/vm-data/centos5 and no graphics. Pretty soon the installer
comes up with "/dev/xvda currently has a loop partition layout.  To use this disk for the installation of CentOS, it must be re-initialized.."
I allow this but create my own partitioning (one Ext3 partition mounted as / with full lv size).
Right after this step, the lv is no longer mountable and when checking the "drive" says wrong superblock.

Is there an issue with LVM on Centos5, or did I do something wrong? ....tried everythign for several hours now :/

[root@serv106 ~]# rpm -qa |grep lvm

I was also considering using file based domU's but still not sure if they would give enough performance for a webhosting (LAMP) server.

Any help, hint or even URL that leads to an actual working howto is greatly appreciated!

Thank you so much and have a great day now!

_______________________________________________ Xen-users mailing list Xen-users@xxxxxxxxxxxxxxxxxxx http://lists.xensource.com/xen-users
Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>