This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Could not set up Dom0 - ELF problem

To: Xen <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: Re: [Xen-users] Could not set up Dom0 - ELF problem
From: Fabiana Milani <milanifaby83@xxxxxxxxx>
Date: Sat, 06 Oct 2007 11:48:35 +0200
Delivery-date: Sat, 06 Oct 2007 02:49:53 -0700
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=beta; h=domainkey-signature:received:received:message-id:date:from:user-agent:mime-version:to:subject:references:in-reply-to:content-type; bh=1/2+eRh5Sssgxi4bfrHpB4afV9SDJjjqGnONHLtprNo=; b=Qn55y03vIfWup4kDZp4evNGTVmayLqwKLK2sRLL0KNMLk6kokDnmbmZPEwsW6+Yrm+SjnV+JDUFB0w+X/zN5oIfgug8TZ1u38V2ylFciVPnaU0sGi4BCG0PqTAlaqx/NFn8E3lTIoSuIOb05qIpTNdUjWBZnZGOLqXgnJzkmICk=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:user-agent:mime-version:to:subject:references:in-reply-to:content-type; b=jW1SyJrkzCCosK+10kWZOZYEH0r4aH2PuK3Ul94TdYk8y0Hhvx/VfRfz6pCJkm1P6xu2FAhdtAEaWQ2nrnz2eYL0zq4Xs1cCwNOsfFDMztc2IqtfRnQbxfhNeZC/Ftw+AcGKJMuMcJjOkEGj2EATe5oKW/+/rPnU6Hz8t3COCUI=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <200710060139.22465.maw48@xxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <4705F3A9.6030701@xxxxxxxxxx> <200710060139.22465.maw48@xxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (Windows/20070728)
Hi, Thank you for your reply.

I've installed on a FC7 system the last version of Xen (xen-3.1.0) from
RPMs of Fedora. After installation and grub configuration, I've rebooted
my system, but the Xen kernel didn't start due to the following error:

Can you post your grub.conf?

I've tried to change my grub.conf file few times, with no results. This is part of the file:

title Telecomlabo
kernel (hd0,5)/boot/vmlinuz root=LABEL=labo resume=LABEL=swap rhgb quiet selinux=0
initrd (hd0,5)/boot/initrd.img
savedefault 0

title TelecomlaboXen
kernel (hd0,5)/boot/xen.gz-2.6.20-2936.fc7 dom0_mem=262144 noreboot
module (hd0,5)/boot/vmlinuz-2.6.20-2936.fc7xen root=LABEL=labo resume=LABEL=swap
module (hd0,5)/boot/initrd-2.6.20-2936.fc7xen.img
savedefault 0

Telecomlabo is the original kernel, and it works fine. Both vmlinuz and initrd.img are symbolic links to the original files. I've deleted rhgd quiet selinux=0 from the Xen version now, but I've tried to boot also with this options, and also without the dom0_mem and noreboot options.

elf_init: not an ELF binary

Panic on CPU 0:
Could not set up DOM0 guest OS/

Sounds like either your grub conf is wrong or the dom0 kernel image has got 


Thank you for your help.

Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>