This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] Permission denied when starting XEN

To: "Mark Williamson" <mark.williamson@xxxxxxxxxxxx>
Subject: Re: [Xen-users] Permission denied when starting XEN
From: Marc <selectmoz@xxxxxxxxx>
Date: Mon, 12 Mar 2007 13:12:31 +0100
Cc: xen-users@xxxxxxxxxxxxxxxxxxx, Jan Albrecht <jan.albrecht@xxxxxxxxx>
Delivery-date: Mon, 12 Mar 2007 05:11:57 -0700
Dkim-signature: a=rsa-sha1; c=relaxed/relaxed; d=gmail.com; s=beta; h=domainkey-signature:received:received:message-id:date:from:reply-to:to:subject:cc:in-reply-to:mime-version:content-type:references; b=t7UQ5PHRyyu7z+PeYXpxph9VJqu+ISq0ZIdOyU1I714hXUHI6HtehHMAH02IR8jXruxa3ek/NTAczPTdqRBBiFV0JnTy5WO9CdFaCq90Vv8CUwl27UVNeezKJPNFPm7JyiDwBj4qEY/qM/Iivgsn43tzfm5rPmIXk+YOraZClek=
Domainkey-signature: a=rsa-sha1; c=nofws; d=gmail.com; s=beta; h=received:message-id:date:from:reply-to:to:subject:cc:in-reply-to:mime-version:content-type:references; b=EvW1202jUsqTrmrwg/7sjVGxAfiozH97ZPsQZEmXiUf2aPaR3lJIPATxZxp0efOVYeP/E9AngTGj20jVJV7HVBhKx8b0pXsneXlJ04ciI3Nu7raIBk7IUnqnBkly83KtqeUtPf5uz3FpfcnOTqN1N8XIT3lc6JkqSzAkc4Jw1Xs=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <200703091411.58345.mark.williamson@xxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <a1ac1b8d0703070809r57cf79d1w190ff7d39db093ea@xxxxxxxxxxxxxx> <45EF9D61.6030109@xxxxxxxxx> <a1ac1b8d0703080146k1cd6e15bj69ee4db2441d5935@xxxxxxxxxxxxxx> <200703091411.58345.mark.williamson@xxxxxxxxxxxx>
Reply-to: marc@xxxxxxxxxx
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
As I did not find what was the problem, I just remove xen and install it again.
Now it works fine !!!  How, why ? I do not know .
Anyway, thanks for your help !!


2007/3/9, Mark Williamson <mark.williamson@xxxxxxxxxxxx>:
You've rebooted into the Xenified kernel right?  I think if you hadn't it
would have given a different error...

Have you recently upgraded, or have you ever installed a new version of the
tools / Xen etc?  If the version of Xen and the version of the tools are not
matched from the same release, it's possible to get errors like this.


On Thursday 08 March 2007 09:46, Marc wrote:
> Hi Jan,
> Yes I tried to start xend as root, and I am also in dom_0.
> Do you think it's a problem of rights between python and XEN ?
> Cheers,
> Marc
> 2007/3/8, Jan Albrecht <jan.albrecht@xxxxxxxxx >:
> > Marc wrote:
> > > Hi all,
> > > I cannot start xend because of this error:
> > > Exception starting xend ((13, 'Permission denied')).
> >
> > Did you start xend as root?
> >
> > Jan

Dave: Just a question. What use is a unicyle with no seat?  And no pedals!
Mark: To answer a question with a question: What use is a skateboard?
Dave: Skateboards have wheels.
Mark: My wheel has a wheel!

Xen-users mailing list

Xen-users mailing list