This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


Re: [Xen-users] powernow-k8 + linux-image-2.6.16-1-xen-k7

To: Ralf Schenk <rs@xxxxxxxxxx>
Subject: Re: [Xen-users] powernow-k8 + linux-image-2.6.16-1-xen-k7
From: John Lenz <jlenz2@xxxxxxxxxxxxx>
Date: Thu, 28 Sep 2006 00:15:12 -0500
Cc: xen-users@xxxxxxxxxxxxxxxxxxx
Delivery-date: Wed, 27 Sep 2006 22:16:05 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <450D24F1.7050306@xxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <450D16D9.5030205@xxxxxx> <450D24F1.7050306@xxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20060922)
On 09/17/06 05:35, Ralf Schenk wrote:
> Hannes Petschauer schrieb:
>> Hi
>> i'm running sarge, xen 3.0.2 with original debian-kernel 2.6.16-1-xen-k7.
>> my problem:
>> when i try to alter cpufrequency in dom0 via
>> /sys/devices/system/cpu/cpu0/cpufreq/scaling_setspeed,
>> it results in an error:
>> powernow-k8: vid trans failed, vid 0x11, curr 0x12
>> when i boot my coputer with non-Xen debian-kernel 2.6.16-1-k7, i have no
>> problem changing cpu-speed.
>> do i have to use a more recent kernel or xen-unstable to get it work
>> (which), or is there a other problem?
>> Thanks!
> You have to patch the kernel to get powernow-k8 running under xen. The
> (small) patch is attached and works for me for kernel 2.6.16.[0-29].
> Bye

I have a dual core chip, and I just tried this patch with the latest
3.0.3-testing release, (kernel, and it does not work.  I get
the error reported in this bug


After applying the patch in that thread, it still doesn't work.  I even
commented out that entire check, and it still fails with the code right
below it ("init not cpu 0" powernow-k8.c:1048)

I suspect it has to do with the fact that I have a dual core chip, and
the xen interface does not currently handle it.  (I notice a comment in
the patch saying something about multiple cpus not working).

For reference, cpufreq works with the stock ubuntu dapper kernel (which
has the patch from that bug applied).  So it is something with the xen


Xen-users mailing list

<Prev in Thread] Current Thread [Next in Thread>