This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] No Device for Second NIC in DomU

To: <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] No Device for Second NIC in DomU
From: Grok Mogger <linuximp@xxxxxxxxx>
Date: Wed, 27 Sep 2006 09:48:44 -0400
Delivery-date: Wed, 27 Sep 2006 06:49:42 -0700
Domainkey-signature: a=rsa-sha1; q=dns; c=nofws; s=beta; d=gmail.com; h=received:to:subject:date:message-id:mime-version:content-type:x-priority:x-msmail-priority:x-mailer:x-mimeole:importance:from; b=DOkyD0anRCBUIiFaGvfBVKH0kDy96fewoVn4BR4d++qkYE5pHl4A6yiw6tEPBjpddzw+UmMh1xL/yu9m5zQUrRc6+/v6rEgV7DCUxS211BZZCiHhb2zr+pN0IjboRj2fPinwvZzC1Iabkvf1Bs33N+L/GXNIZQ0HSwELoW9Kd7g=
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
Importance: Normal
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
I am running Xen 3.0.2 on a minimal installation of Debian etch.  I have two DomU's, both also running Debian etch.  This was all installed within the past few days, so it's the latest stuff.
I'm running on Dell server hardware purchased in November of 2005, so it's fairly new and pretty powerful.  I don't know for a fact, but I think it's safe to assume that the two NIC's are identical.
I cannot get the second NIC interface working in either DomU, even though the first works just fine.  When I try to do an "ifup eth1", I get the following errors.
SIOCSIFADDR: No such device
eth1: ERROR while getting interface flags: No such device
SIOCSIFNETMASK: No such device
SIOCSIFBRDADDR: No such device
eth1: ERROR while getting interface flags: No such device
eth1: ERROR while getting interface flags: No such device
Failed to bring up eth1.
Note that eth0 is working perfectly, and I get this exact same error message in both DomU's if I try to bring up eth1.
I have made my own wrapper script to call network-bridge twice, and everything in Dom0 looks great.  I have two bridges, the right virtual interfaces, and my Dom0 eth1 works great.
This might be related...  I just tried to start one of my DomU's and got this error message...
"Error: Device 0 (vif) could not be connected. Hotplug scripts not working."
That hasn't happened before.  I ignored the error and tried to start the domain again...  and it worked the second time.
Any help would be greatly appreciated.  I am completely baffled, so even suggesting something to try would be helpful.  Please keep in mind I am still something of a Linux / Xen n00b.  =)
- GM
Xen-users mailing list
<Prev in Thread] Current Thread [Next in Thread>
  • [Xen-users] No Device for Second NIC in DomU, Grok Mogger <=