This is an archived copy of the Xen.org mailing list, which we have preserved to ensure that existing links to archives are not broken. The live archive, which contains the latest emails, can be found at http://lists.xen.org/
Home Products Support Community News


[Xen-users] Re: [Xen-devel] xenguest-install.py reports "no module named

To: shobha ranganathan <shobha_ranganathan@xxxxxxxxx>, Xen-users <xen-users@xxxxxxxxxxxxxxxxxxx>
Subject: [Xen-users] Re: [Xen-devel] xenguest-install.py reports "no module named libvirt" in FC5 x86 mode
From: Anthony Liguori <aliguori@xxxxxxxxxx>
Date: Tue, 26 Sep 2006 17:21:53 -0500
Delivery-date: Tue, 26 Sep 2006 15:24:26 -0700
Envelope-to: www-data@xxxxxxxxxxxxxxxxxx
In-reply-to: <20060926214135.77243.qmail@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
List-help: <mailto:xen-users-request@lists.xensource.com?subject=help>
List-id: Xen user discussion <xen-users.lists.xensource.com>
List-post: <mailto:xen-users@lists.xensource.com>
List-subscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=subscribe>
List-unsubscribe: <http://lists.xensource.com/cgi-bin/mailman/listinfo/xen-users>, <mailto:xen-users-request@lists.xensource.com?subject=unsubscribe>
References: <20060926214135.77243.qmail@xxxxxxxxxxxxxxxxxxxxxxxxxxx>
Sender: xen-users-bounces@xxxxxxxxxxxxxxxxxxx
User-agent: Thunderbird (X11/20060922)
Please don't cross-post.

xenguest-install.py is not part of upstream Xen. It's RedHat specific. Please ask in the fedora-xen users list.


Anthony Liguori

shobha ranganathan wrote:
I download xen3.0.2-23.src.rpm and build the dom0 Kernel in Fedora COre 5 in x86 mode. I did not build a domU kernel at all. I tried to run ./xenguest-install.py in dom0 kernel after booting into it.. I got this error
"No module named libvirt".
I then tried installing libvirt-0.0.6-1.i386.rpm using
"rpm --install libvirt-0.0.6-1.i386.rpm"
I get failed dependencies error such as
"libxenstore.so is needed by libvirt-0.0.6-1.i386
xen is needed by libvirt-0.0.6-1.i386"
what am I missing here ? I have libxenstore.so in /usr/lib. thanks for your help

Stay in the know. Pulse on the new Yahoo.com. Check it out. <http://us.rd.yahoo.com/evt=42974/*http://www.yahoo.com/preview>

Xen-devel mailing list

Xen-users mailing list